[Bug 29896] New: The datatables api wrapper is ambiguously named - OPAC
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 Bug ID: 29896 Summary: The datatables api wrapper is ambiguously named - OPAC Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: david@davidnind.com, dcook@prosentient.com.au, fridolin.somers@biblibre.com, jonathan.druart+koha@gmail.com, kyle@bywatersolutions.com, oleonard@myacpl.org, tomascohen@gmail.com, victor@tuxayo.net Depends on: 29408 +++ This bug was initially created as a clone of Bug #29408 +++ The dataTables Koha REST wrapper we added recently is badly named.. currently, it's the very unspecific 'api'.. we should start using a consistent naming convention for such JS wrapper functions. In bug 29397 we introduce a minimal select2 wrapper and call it kohaSelect.. I propose we take that as inspiration and rename the dataTables function from 'api' to 'kohaTable'. Thus, creating a new API driven dataTable would become: $(".selector").kohaTable(usual stuff here); Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29408 [Bug 29408] The datatables api wrapper is ambiguously named -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|The datatables api wrapper |Sync the functionality of |is ambiguously named - OPAC |the datatables api wrapper | |on the OPAC with the Staff | |Client equivilent -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Reworking this a bit.. lots of functionality is missing from the OPAC version -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 129540 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129540&action=edit Bug 29896: Update datatables wrapper in the OPAC This patch updates the datatables api wrapper from 'api' to 'kohaTable' to match the function of the same intention with the name in the staff client. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- As far as I can tell.. this wrapper function isn't actually used anywhere in the OPAC as yet.. so I'll leave it here and when we come to use it I can pick the code back up again. We need to implement the column ordering fixes, the match type fixes and the column filters fixes at some point.. assuming we need them at the OPAC. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org