https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29896 Bug ID: 29896 Summary: The datatables api wrapper is ambiguously named - OPAC Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: david@davidnind.com, dcook@prosentient.com.au, fridolin.somers@biblibre.com, jonathan.druart+koha@gmail.com, kyle@bywatersolutions.com, oleonard@myacpl.org, tomascohen@gmail.com, victor@tuxayo.net Depends on: 29408 +++ This bug was initially created as a clone of Bug #29408 +++ The dataTables Koha REST wrapper we added recently is badly named.. currently, it's the very unspecific 'api'.. we should start using a consistent naming convention for such JS wrapper functions. In bug 29397 we introduce a minimal select2 wrapper and call it kohaSelect.. I propose we take that as inspiration and rename the dataTables function from 'api' to 'kohaTable'. Thus, creating a new API driven dataTable would become: $(".selector").kohaTable(usual stuff here); Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29408 [Bug 29408] The datatables api wrapper is ambiguously named -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.