[Bug 23252] New: Missing input_marceditor class in item editor
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Bug ID: 23252 Summary: Missing input_marceditor class in item editor Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Cataloging Assignee: koha-bugs@lists.koha-community.org Reporter: fridolin.somers@biblibre.com QA Contact: testopia@bugs.koha-community.org CC: m.de.rooy@rijksmuseum.nl In serials receive and acquisition order creation from iso2709, the item edition form shows inputs that are missing "input_marceditor" class. They are also missing tabindex and id. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |fridolin.somers@biblibre.co |ity.org |m Status|NEW |ASSIGNED -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #1 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Created attachment 91187 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=91187&action=edit Bug 23252: Add missing input_marceditor class in item editor In serials receive and acquisition order creation from iso2709, the item edition form shows inputs that are missing "input_marceditor" class. They are also missing tabindex and id. The side effect is that those inputs dont get the "noEnterSubmit" class so form is posted if a barcode scanner is used or if enter is used on keyboard. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify system preference "AcqCreateItem" is on "placing an order" 2) 2.2) Go to cataloguing module and edit an item 2.3) Verify that $z has an id, tabindex and "input_marceditor" class. 2.4) Verify that typing enter in $z does not submit the form 3) 3.1) Go to a serial with items creation, click on receive 3.2) Change status to "Arrived" 3.3) Verify that $z has an id, tabindex and "input_marceditor" class. 3.4) Verify that typing enter in $z does not submit the form 4) 4.1) Go to an acquisition basket 4.2) Click "Add to basket" and "From a staged file" 4.3) Click "Add orders" on a staged file 4.4) Go in tab "Item information" 4.5) Verify that $z has an id, tabindex and "input_marceditor" class. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #2 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Fridolin SOMERS from comment #1)
The side effect is that those inputs dont get the "noEnterSubmit" class so form is posted if a barcode scanner is used or if enter is used on keyboard.
But will everyone appreciate that change ? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #3 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- (In reply to Marcel de Rooy from comment #2)
(In reply to Fridolin SOMERS from comment #1)
The side effect is that those inputs dont get the "noEnterSubmit" class so form is posted if a barcode scanner is used or if enter is used on keyboard.
But will everyone appreciate that change ?
This is the behavior for item edition in cataloging module. Having the same behavior in serials module is wanted I think. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|normal |major --- Comment #4 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- I set major because it is difficult to correct serials once form is posted too early -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #5 from Christophe Croullebois <christophe.croullebois@biblibre.com> --- Created attachment 92497 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=92497&action=edit Bug 23252: Adds noEnterSubmit class in ajax context In cataloging.js $(document).ready adds noEnterSubmit class. This does not work in ajax context, it works with $(document).ajaxSuccess. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify 952$z exists in ACQ framework 2) 2.1) Verify system preference "AcqCreateItem" is on "placing an order" 2.2) Go to an acquisition basket 2.3) Click "Add to basket" and "From a new (empty) record" 2.4) Go to "Item" block 2.5) Verify that $z has "noEnterSubmit" class 2.6) Verify that typing enter in $z does not submit the form 3) 3.1) Change system preference "AcqCreateItem" to "receiving an order" 3.2) Go to "Receive shipment" 3.3) Receive an order 3.4) Go to "Item" block 3.5) Verify that $z has "noEnterSubmit" class 3.6) Verify that typing enter in $z does not submit the form -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #91187|0 |1 is obsolete| | Attachment #92497|0 |1 is obsolete| | --- Comment #6 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 92630 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=92630&action=edit Bug 23252: Add missing input_marceditor class in item editor In serials receive and acquisition order creation from iso2709, the item edition form shows inputs that are missing "input_marceditor" class. They are also missing tabindex and id. The side effect is that those inputs dont get the "noEnterSubmit" class so form is posted if a barcode scanner is used or if enter is used on keyboard. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify system preference "AcqCreateItem" is on "placing an order" 2) 2.2) Go to cataloguing module and edit an item 2.3) Verify that $z has an id, tabindex and "input_marceditor" class. 2.4) Verify that typing enter in $z does not submit the form 3) 3.1) Go to a serial with items creation, click on receive 3.2) Change status to "Arrived" 3.3) Verify that $z has an id, tabindex and "input_marceditor" class. 3.4) Verify that typing enter in $z does not submit the form 4) 4.1) Go to an acquisition basket 4.2) Click "Add to basket" and "From a staged file" 4.3) Click "Add orders" on a staged file 4.4) Go in tab "Item information" 4.5) Verify that $z has an id, tabindex and "input_marceditor" class. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #7 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 92631 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=92631&action=edit Bug 23252: Adds noEnterSubmit class in ajax context In cataloging.js $(document).ready adds noEnterSubmit class. This does not work in ajax context, it works with $(document).ajaxSuccess. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify 952$z exists in ACQ framework 2) 2.1) Verify system preference "AcqCreateItem" is on "placing an order" 2.2) Go to an acquisition basket 2.3) Click "Add to basket" and "From a new (empty) record" 2.4) Go to "Item" block 2.5) Verify that $z has "noEnterSubmit" class 2.6) Verify that typing enter in $z does not submit the form 3) 3.1) Change system preference "AcqCreateItem" to "receiving an order" 3.2) Go to "Receive shipment" 3.3) Receive an order 3.4) Go to "Item" block 3.5) Verify that $z has "noEnterSubmit" class 3.6) Verify that typing enter in $z does not submit the form Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Bouzid Fergani <bouzid.fergani@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #92630|0 |1 is obsolete| | --- Comment #8 from Bouzid Fergani <bouzid.fergani@inlibro.com> --- Created attachment 93050 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=93050&action=edit Bug 23252: Add missing input_marceditor class in item editor In serials receive and acquisition order creation from iso2709, the item edition form shows inputs that are missing "input_marceditor" class. They are also missing tabindex and id. The side effect is that those inputs dont get the "noEnterSubmit" class so form is posted if a barcode scanner is used or if enter is used on keyboard. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify system preference "AcqCreateItem" is on "placing an order" 2) 2.2) Go to cataloguing module and edit an item 2.3) Verify that $z has an id, tabindex and "input_marceditor" class. 2.4) Verify that typing enter in $z does not submit the form 3) 3.1) Go to a serial with items creation, click on receive 3.2) Change status to "Arrived" 3.3) Verify that $z has an id, tabindex and "input_marceditor" class. 3.4) Verify that typing enter in $z does not submit the form 4) 4.1) Go to an acquisition basket 4.2) Click "Add to basket" and "From a staged file" 4.3) Click "Add orders" on a staged file 4.4) Go in tab "Item information" 4.5) Verify that $z has an id, tabindex and "input_marceditor" class. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Bouzid Fergani <bouzid.fergani@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Bouzid Fergani <bouzid.fergani@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #92631|0 |1 is obsolete| | --- Comment #9 from Bouzid Fergani <bouzid.fergani@inlibro.com> --- Created attachment 93051 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=93051&action=edit Bug 23252: Adds noEnterSubmit class in ajax context In cataloging.js $(document).ready adds noEnterSubmit class. This does not work in ajax context, it works with $(document).ajaxSuccess. Test plan : 1) 1.1) Verify you have an item subfield linked to items.itemnotes, ie 952$z 1.2) Verify 952$z exists in ACQ framework 2) 2.1) Verify system preference "AcqCreateItem" is on "placing an order" 2.2) Go to an acquisition basket 2.3) Click "Add to basket" and "From a new (empty) record" 2.4) Go to "Item" block 2.5) Verify that $z has "noEnterSubmit" class 2.6) Verify that typing enter in $z does not submit the form 3) 3.1) Change system preference "AcqCreateItem" to "receiving an order" 3.2) Go to "Receive shipment" 3.3) Receive an order 3.4) Go to "Item" block 3.5) Verify that $z has "noEnterSubmit" class 3.6) Verify that typing enter in $z does not submit the form Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Bouzid Fergani <bouzid.fergani@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Bouzid Fergani <bouzid.fergani@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |bouzid.fergani@inlibro.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #10 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- $(document).ready(function() { $("input.input_marceditor, input.indicator").addClass('noEnterSubmit'); + $(document).ajaxSuccess(function() { + $("input.input_marceditor, input.indicator").addClass('noEnterSubmit'); + }); }); Christophe: I am having the impression that only orderreceive needs this. In the context of cataloging.js and its broader use, it seems to me that adding it closer to the needed location would be better? Please confirm. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #11 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- (In reply to Marcel de Rooy from comment #10)
$(document).ready(function() { $("input.input_marceditor, input.indicator").addClass('noEnterSubmit'); + $(document).ajaxSuccess(function() { + $("input.input_marceditor, input.indicator").addClass('noEnterSubmit'); + }); });
Christophe: I am having the impression that only orderreceive needs this. In the context of cataloging.js and its broader use, it seems to me that adding it closer to the needed location would be better? Please confirm.
Actually indeed, but for me having all in cataloging.js is better. Imagine we change the name of the class "input_marceditor". Or if we change serials receive to use Ajax. Thanks a lot for your time :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Missing input_marceditor |Pressing enter should not |class in item editor |submit form in item editor -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Alias| |Missing, input_marceditor, | |class, in, item, editor -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Alias|class, editor, in, | |input_marceditor, item, | |Missing | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- It looks like this is actually a regressen - we fixed it before in bug 8557. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com Status|Signed Off |Passed QA --- Comment #13 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- This looks solid to me, I've noted Marcelr's comment but believe we're safe here given the responses and a look at the code myself.. Passing QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |19.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 --- Comment #14 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Nice work! Pushed to master for 19.11.00 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23252 Fridolin SOMERS <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)|19.11.00 |19.11.00,19.05.05 released in| | Status|Pushed to master |Pushed to stable --- Comment #15 from Fridolin SOMERS <fridolin.somers@biblibre.com> --- Pushed to 19.05.x for 19.05.05 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org