[Bug 38205] New: 'bookable' should be queryable on the /items endpoint
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 Bug ID: 38205 Summary: 'bookable' should be queryable on the /items endpoint Change sponsored?: --- Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Circulation Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com Depends on: 35906 We added further support for bookable on the /biblio/{biblio_id}/items endpoint.. we should really replicate that on the /items endpoint including enhancing the support from just ?bookable= param to the q= param handling. I also think we should rename from bookable to effective_bookable because that's what the special handling actually uses now. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35906 [Bug 35906] Add bookable option on itemtypes -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 --- Comment #1 from Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> ---
From bug 35906 comment 85
We should support the ?bookable filter on the plain /api/v1/items endpoint too. Also.. I'm tempted to rename it 'effective_bookable' to more clearly distinguish been effective bookable and localised item bookable fields. I'd love to see this also taken account of within q= as well as the local param option.. that could be a future follow-up though. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I like the idea to follow the pattern with effective_ here. Would it make sense to expose both, the item level information and the combined status from item type and item or is the latter enough really? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 Bug 38205 depends on bug 35906, which changed state. Bug 35906 Summary: Add bookable option on itemtypes https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35906 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38205 Tomás Cohen Arazi (tcohen) <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |tomascohen@gmail.com --- Comment #3 from Tomás Cohen Arazi (tcohen) <tomascohen@gmail.com> --- I like the idea of having a ?bookable=1 filter in both controller methods. I don't like the fact the 'effective_*' attributes are returned without an embed. Because we end up answering in chat or support tickets questions about weird 500 errors caused by passing those attributes. When it is an embed, the docs at least can add `(x-koha-embed)` on the side so consumers know what to expect. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org