[Bug 33223] New: Koha::Patron->notice_email_address isn't consistently used
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Bug ID: 33223 Summary: Koha::Patron->notice_email_address isn't consistently used Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Notices Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org Depends on: 18398, 33192 As highlighted in bug 33192, we're not consistently using the Koha::Patron->notice_email_address method to get our 'to' address for notices. This bug serves to catch the last remaining cases where it's not being used and should be. Copying the list from the above bug, notice_email_address is used in: C4::Auth_With_shibboleth C4::Letters (as the default) C4::Auth - For 2FA C4::Auth_with_ldap C4::Reserves shareshelf.pl memberentry.pl opac-registration-varify.pl two_factor_auth.pl notice.pl memberentry.pl pendingreserves.pl Koha::Ticket Patron::Import.pm suggestion.pl overdue_notices.pl TalkingTech_iteive_outbound.pl notice_unprocessed_suggestions.pm first_valid_email is used in: clubs-tab.tt waiting_holds.inc transferstoreceive.tt opac-sendbasket.pl Koha::SharedContent Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18398 [Bug 18398] CHECKIN/CHECKOUT/RENEWAL don't use AutoEmailPrimaryAddress but first valid e-mail https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 [Bug 33192] We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com, | |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 148168 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148168&action=edit Bug 33223: Replace 'first_valid' with 'notice' for email addresses This patch replaces the uses of first_valid_email_address with notice_email_address in waiting_holds, transferstoreceive, clubs and sendbasket so that we take EmailFieldPrimary into account for these notices too. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |normal -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #2 from David Cook <dcook@prosentient.com.au> --- I'll be wanting to look more at these. Sounds very useful. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Patch doesn't apply --- Comment #3 from David Cook <dcook@prosentient.com.au> --- Bug 33223 - Koha::Patron->notice_email_address isn't consistently used 148168 - Bug 33223: Replace 'first_valid' with 'notice' for email addresses Apply? [(y)es, (n)o, (i)nteractive] y Applying: Bug 33223: Replace 'first_valid' with 'notice' for email addresses Using index info to reconstruct a base tree... M koha-tmpl/intranet-tmpl/prog/en/modules/circ/transferstoreceive.tt M opac/opac-sendbasket.pl Falling back to patching base and 3-way merge... Auto-merging opac/opac-sendbasket.pl CONFLICT (content): Merge conflict in opac/opac-sendbasket.pl Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/circ/transferstoreceive.tt error: Failed to merge in the changes. Patch failed at 0001 Bug 33223: Replace 'first_valid' with 'notice' for email addresses hint: Use 'git am --show-current-patch' to see the failed patch When you have resolved this problem run "git bz apply --continue". If you would prefer to skip this patch, instead run "git bz apply --skip". To restore the original branch and stop patching run "git bz apply --abort". Patch left in /tmp/Bug-33223-Replace-firstvalid-with-notice-for-email-t8SwfM.patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148168|0 |1 is obsolete| | --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 151023 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151023&action=edit Bug 33223: Replace 'first_valid' with 'notice' for email addresses This patch replaces the uses of first_valid_email_address with notice_email_address in waiting_holds, transferstoreceive, clubs and sendbasket so that we take EmailFieldPrimary into account for these notices too. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Patch doesn't apply |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=12532 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |12532 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12532 [Bug 12532] Redirect guarantee email to guarantor -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151023|0 |1 is obsolete| | --- Comment #5 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 151024 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151024&action=edit Bug 33223: Replace 'first_valid' with 'notice' for email addresses This patch replaces the uses of first_valid_email_address with notice_email_address in waiting_holds, transferstoreceive, clubs and sendbasket so that we take EmailFieldPrimary into account for these notices too. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #6 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 151025 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151025&action=edit Bug 33223: Fix sendshelf Two new occurences of first_valid crept in, this patch corrects those to also use notice_ -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |3150 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3150 [Bug 3150] Move emails for sending cart and list contents into notices tool -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151024|0 |1 is obsolete| | --- Comment #7 from David Cook <dcook@prosentient.com.au> --- Created attachment 151041 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151041&action=edit Bug 33223: Replace 'first_valid' with 'notice' for email addresses This patch replaces the uses of first_valid_email_address with notice_email_address in waiting_holds, transferstoreceive, clubs and sendbasket so that we take EmailFieldPrimary into account for these notices too. Signed-off-by: David Cook <dcook@prosentient.com.au> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151025|0 |1 is obsolete| | --- Comment #8 from David Cook <dcook@prosentient.com.au> --- Created attachment 151042 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151042&action=edit Bug 33223: Fix sendshelf Two new occurences of first_valid crept in, this patch corrects those to also use notice_ Signed-off-by: David Cook <dcook@prosentient.com.au> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #9 from David Cook <dcook@prosentient.com.au> --- Patches apply and change looks good upon review. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl --- Comment #10 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Looking here, although I feel that this patch is somewhere between bug and enh actually. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |BLOCKED QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #11 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Looking at what remains for first_valid_email i would opt for removing the OFF option of EmailFieldPrimary and default it to the email field. Here it is only used as boolean: $params->{is_email_required} = 0 unless $self->first_valid_email_address(); Koha/SharedContent.pm: $mana_email = $borrower->first_valid_email_address This one could be replaced imo by notice_email. But yes, not here :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|BLOCKED |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151041|0 |1 is obsolete| | --- Comment #12 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 151117 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151117&action=edit Bug 33223: Replace 'first_valid' with 'notice' for email addresses This patch replaces the uses of first_valid_email_address with notice_email_address in waiting_holds, transferstoreceive, clubs and sendbasket so that we take EmailFieldPrimary into account for these notices too. Signed-off-by: David Cook <dcook@prosentient.com.au> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #151042|0 |1 is obsolete| | --- Comment #13 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 151118 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=151118&action=edit Bug 33223: Fix sendshelf Two new occurences of first_valid crept in, this patch corrects those to also use notice_ Signed-off-by: David Cook <dcook@prosentient.com.au> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Bug 33223 depends on bug 3150, which changed state. Bug 3150 Summary: Move emails for sending cart and list contents into notices tool https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3150 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Bug 33223 depends on bug 33192, which changed state. Bug 33192 Summary: We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |23.05.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 --- Comment #14 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.05. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Bug 33223 depends on bug 18398, which changed state. Bug 18398 Summary: CHECKIN/CHECKOUT/RENEWAL don't use AutoEmailPrimaryAddress but first valid e-mail https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18398 What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to oldstable |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to master |RESOLVED CC| |matt.blenkinsop@ptfs-europe | |.com Resolution|--- |FIXED --- Comment #15 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Missing dependencies - not backporting to 22.11.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=36008 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org