[Bug 14054] New: 246 XSLT Improvements
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Bug ID: 14054 Summary: 246 XSLT Improvements Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Templates Assignee: oleonard@myacpl.org Reporter: nengard@gmail.com QA Contact: testopia@bugs.koha-community.org Depends on: 13386 246 2nd indicator specifies type of other title, would be nice to display that when 1st indicator 1. Probaby it would go into brackets like relator terms and would be overridden by subfield i -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Nicole C. Engard <nengard@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|13386 | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Winona Salesky <wsalesky@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #1 from Winona Salesky <wsalesky@gmail.com> --- Created attachment 39831 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=39831&action=edit Bug 14054 - 246 XSLT Improvements Add title type in brackets for field 246 based on 2nd indicator. Overridden by subfield i. Applies to OPAC and staff details. Test Plan: 1) Apply this patch 2) Ensure you are using the default XSLT setting for the staff and opac search results and record details 3) Find or create a record with MARC tags 246 with populated ind2 4) Title types are added in brackets following title, unless subfield i exists. Then ind2 value is suppressed. 6) Repeat test for the staff interface -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Nick Clemens <nick@quecheelibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |nick@quecheelibrary.org --- Comment #2 from Nick Clemens <nick@quecheelibrary.org> --- Yay! It works! Thank you! And now a question: Should subfield i also go into brackets when it overrides the 2nd indicator? I think that would make it easier to read too. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Winona Salesky <wsalesky@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |wsalesky@gmail.com --- Comment #3 from Winona Salesky <wsalesky@gmail.com> --- We could do that. Should the display force subfield i to occur at the end as with the titles generated by the indicator? (Makes the most sense to me.) (In reply to Nick Clemens from comment #2)
Yay! It works! Thank you!
And now a question: Should subfield i also go into brackets when it overrides the 2nd indicator? I think that would make it easier to read too.
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #4 from Nick Clemens <nick@quecheelibrary.org> ---
Should the display force subfield i to occur at the end as with the titles generated by the indicator? (Makes the most sense to me.)
I agree, that makes sense -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #5 from Winona Salesky <wsalesky@gmail.com> --- Should this apply in both details and results view? Currently only implemented in details view, it may clutter up the results view to have it in both, but I'm flexible. -Winona (In reply to Nick Clemens from comment #4)
Should the display force subfield i to occur at the end as with the titles generated by the indicator? (Makes the most sense to me.)
I agree, that makes sense
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Winona Salesky <wsalesky@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #39831|0 |1 is obsolete| | --- Comment #6 from Winona Salesky <wsalesky@gmail.com> --- Created attachment 40020 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40020&action=edit Bug 14054 - 246 XSLT Improvements Adds other title type based on ind2 value. ind2 overridden by $i value. Test Plan: 1) Apply this patch 2) Ensure you are using the default XSLT setting for the staff and opac search results and record details 3) Find or create a record with MARC tags 246 with populated ind2 4) Title types are added in brackets following title, unless subfield i exists. Then ind2 value is suppressed. 6) Repeat test for the staff interface -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #7 from Nick Clemens <nick@quecheelibrary.org> --- Looking very good! Going back to the initial bug filing, I think 246 2nd indicator should display for first indicator either 0 or 1. According to MARC the values are: First Indicator Note/added entry controller 0 - Note, no added entry 1 - Note, added entry 2 - No note, no added entry 3 - No note, added entry I don't know if 2 or 3 actually means you are not supposed to display the title at all, but I always prefer seeing it so am not rocking that boat unless someone else wants to chime in. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #8 from Winona Salesky <wsalesky@gmail.com> --- Anyone else have an opinion on the first indicator? Should 246 only display for ind1=1 or 0? Thanks! -Winona (In reply to Nick Clemens from comment #7)
Looking very good!
Going back to the initial bug filing, I think 246 2nd indicator should display for first indicator either 0 or 1. According to MARC the values are:
First Indicator Note/added entry controller 0 - Note, no added entry 1 - Note, added entry 2 - No note, no added entry 3 - No note, added entry
I don't know if 2 or 3 actually means you are not supposed to display the title at all, but I always prefer seeing it so am not rocking that boat unless someone else wants to chime in.
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Indranil Das Gupta <indradg@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #40020|0 |1 is obsolete| | --- Comment #9 from Indranil Das Gupta <indradg@gmail.com> --- Created attachment 40212 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40212&action=edit Bug 14054 - 246 XSLT Improvements Adds other title type based on ind2 value. ind2 overridden by $i value. Signed-off-by: Indranil Das Gupta (L2C2 Technologies) <indradg@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Indranil Das Gupta <indradg@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off CC| |indradg@gmail.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|oleonard@myacpl.org |wsalesky@gmail.com CC| |m.de.rooy@rijksmuseum.nl Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #10 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Can I have a more detailed test plan please, I don't manage to see the difference pre and post patch. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #40212|0 |1 is obsolete| | --- Comment #11 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 42802 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=42802&action=edit Bug 14054 - 246 XSLT Improvements Adds other title type based on ind2 value. ind2 overridden by $i value. Signed-off-by: Indranil Das Gupta (L2C2 Technologies) <indradg@gmail.com> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #12 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- ok sorry, I was not using the correct XSLT file :-/ -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |tomascohen@gmail.com --- Comment #13 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patch pushed to master. Thanks Winona! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 --- Comment #14 from Winona Salesky <wsalesky@gmail.com> --- Great! Thank you, -Winona (In reply to Tomás Cohen Arazi from comment #13)
Patch pushed to master.
Thanks Winona!
-- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14054 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de Component|Templates |MARC Bibliographic data | |support -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org