[Bug 10823] New: add class info to enumchron data in detail.tt, for better styling
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Bug ID: 10823 Summary: add class info to enumchron data in detail.tt, for better styling Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Templates Assignee: oleonard@myacpl.org Reporter: mtj@kohaaloha.com QA Contact: testopia@bugs.koha-community.org this is a trivial patch with no functional change this patch adds class info to the item.serialseq and item.publisheddate values, to allow better styling -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #1 from Mason James <mtj@kohaaloha.com> --- Created attachment 20790 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=20790&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Marking this 'Needs Signoff', as it has a patch, but we need to check if the change is still needed and we might prefer using a <span> instead of a <div> tag. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtompset@hotmail.com --- Comment #3 from M. Tompsett <mtompset@hotmail.com> --- How does this related to bug 10825? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Nicole C. Engard <nengard@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA CC| |nengard@gmail.com --- Comment #4 from Nicole C. Engard <nengard@gmail.com> --- After applying this patch all info in the enumchron column in the staff client disappeared for me ... -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Nicole C. Engard <nengard@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|oleonard@myacpl.org |mtj@kohaaloha.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #5 from M. Tompsett <mtompset@hotmail.com> --- Comment on attachment 20790 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=20790 Bug 10823 - add class info to enumchron data in detail.tt, for better styling Review of attachment 20790: --> (http://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=10823&attachment=20790) ----------------------------------------------------------------- ::: koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt @@ +513,5 @@
+ [% END %] + [% IF ( itemloo.serialseq ) %] + <div class="serialseq"> -- [% itemloo.serialseq %]</div> + [% END %] + [% IF ( itemloo.publisheddate ) %]
These say 'itemloo' vs. 'item' in the previous code. This is why it disappeared for Nicole. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #20790|0 |1 is obsolete| | --- Comment #6 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 26709 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=26709&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling By adding div tags, styling ability can be improved. This included serialseq and pubdate classes. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=10825 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #7 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Comment on attachment 26709 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=26709 Bug 10823 - add class info to enumchron data in detail.tt, for better styling Hm, why a div and not a span? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #26709|0 |1 is obsolete| | --- Comment #8 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 27073 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27073&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling By adding span tags, styling ability can be improved. This included serialseq and pubdate classes. This update reflects suggestions by Katrin (comment #7) and a conversation with oleonard our resident expert. (http://irc.koha-community.org/koha/2014-04-03#i_1491135) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #20790|1 |0 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27073|0 |1 is obsolete| | --- Comment #9 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 27074 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27074&action=edit Bug 10823 - Follow up to correct problem with origin patch This fixes the itemloo's by changing them to item. This update reflects suggestions by Katrin (comment #7) and a conversation with oleonard our resident expert. (http://irc.koha-community.org/koha/2014-04-03#i_1491135) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27074|0 |1 is obsolete| | --- Comment #10 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 27075 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27075&action=edit Bug 10823 - Follow up to correct problem with origin patch This fixes the itemloo's by changing them to item. This restores proper logic for the --'s. This update reflects suggestions by Katrin (comment #7) and a conversation with oleonard our resident expert. (http://irc.koha-community.org/koha/2014-04-03#i_1491135) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |10825 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #11 from Mason James <mtj@kohaaloha.com> --- Created attachment 27085 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27085&action=edit Bug 10823 - Follow up to add <span> to '--' -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27075|0 |1 is obsolete| | --- Comment #12 from Mason James <mtj@kohaaloha.com> --- Created attachment 27086 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27086&action=edit Bug 10823 - Follow up to correct problem with origin patch This fixes the itemloo's by changing them to item. This restores proper logic for the --'s. This update reflects suggestions by Katrin (comment #7) and a conversation with oleonard our resident expert. (http://irc.koha-community.org/koha/2014-04-03#i_1491135) Signed-off-by: Mason James <mtj@kohaaloha.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27085|0 |1 is obsolete| | --- Comment #13 from Mason James <mtj@kohaaloha.com> --- Created attachment 27087 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27087&action=edit Bug 10823 - Follow up to add <span> to '--' -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 --- Comment #14 from Mason James <mtj@kohaaloha.com> --- bug needs sign-off on patch 1 and 3... -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks|10825 | Depends on| |10825 See Also|http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=10825 | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #20790|0 |1 is obsolete| | Attachment #27086|0 |1 is obsolete| | Attachment #27087|0 |1 is obsolete| | --- Comment #15 from Mason James <mtj@kohaaloha.com> --- Created attachment 27091 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27091&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling squashing 3 patches, and rebasing after 10825 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Mason James <mtj@kohaaloha.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27091|0 |1 is obsolete| | --- Comment #16 from Mason James <mtj@kohaaloha.com> --- Created attachment 27092 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27092&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling squashing 3 patches, and rebasing after 10825 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27092|0 |1 is obsolete| | --- Comment #17 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 27103 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27103&action=edit Bug 10823 - add class info to enumchron data in detail.tt, for better styling Bug 10825 removes a duplicate (enumchron==serialseq). This patch was developed on top of it. It properly styles the elements. These include: - items.enumchron - the separator used - serial.serialseq - items.publisheddate As per Katrin's and Owen's suggestion, <span> was used instead of <div>. (See comment #7 and http://irc.koha-community.org/koha/2014-04-03#i_1491135) TEST PLAN --------- 1) Apply patch 10825 2) Find a biblio where the enumchron and serialseq are different. -- in MySQL: SELECT items.biblionumber,items.enumchron,serial.serialseq FROM items,serial,serialitems WHERE items.itemnumber=serilaitems.itemnumber AND serialitems.serialid=serial.serialid; 3) In the staff client, view the source for that item. -- It should be one class for the entire <td> cell. 4) Apply patch 10823 5) Refresh the page 6) Look at the source for that item again. -- It should have <span> tags around the 4 things listed above. 7) Run the koha qa test tools. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> NOTE: Since there was lots of squashing and rebasing, could you please test and sign this off as well, Mason? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27103|0 |1 is obsolete| | --- Comment #18 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 27536 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27536&action=edit [SIGNED-OFF] Bug 10823 - add class info to enumchron data in detail.tt, for better styling Bug 10825 removes a duplicate (enumchron==serialseq). This patch was developed on top of it. It properly styles the elements. These include: - items.enumchron - the separator used - serial.serialseq - items.publisheddate As per Katrin's and Owen's suggestion, <span> was used instead of <div>. (See comment #7 and http://irc.koha-community.org/koha/2014-04-03#i_1491135) TEST PLAN --------- 1) Apply patch 10825 2) Find a biblio where the enumchron and serialseq are different. -- in MySQL: SELECT items.biblionumber,items.enumchron,serial.serialseq FROM items,serial,serialitems WHERE items.itemnumber=serilaitems.itemnumber AND serialitems.serialid=serial.serialid; 3) In the staff client, view the source for that item. -- It should be one class for the entire <td> cell. 4) Apply patch 10823 5) Refresh the page 6) Look at the source for that item again. -- It should have <span> tags around the 4 things listed above. 7) Run the koha qa test tools. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> NOTE: Since there was lots of squashing and rebasing, could you please test and sign this off as well, Mason? Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #27536|0 |1 is obsolete| | --- Comment #19 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 27650 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=27650&action=edit [PASSED QA] Bug 10823 - add class info to enumchron data in detail.tt, for better styling Bug 10825 removes a duplicate (enumchron==serialseq). This patch was developed on top of it. It properly styles the elements. These include: - items.enumchron - the separator used - serial.serialseq - items.publisheddate As per Katrin's and Owen's suggestion, <span> was used instead of <div>. (See comment #7 and http://irc.koha-community.org/koha/2014-04-03#i_1491135) TEST PLAN --------- 1) Apply patch 10825 2) Find a biblio where the enumchron and serialseq are different. -- in MySQL: SELECT items.biblionumber,items.enumchron,serial.serialseq FROM items,serial,serialitems WHERE items.itemnumber=serilaitems.itemnumber AND serialitems.serialid=serial.serialid; 3) In the staff client, view the source for that item. -- It should be one class for the entire <td> cell. 4) Apply patch 10823 5) Refresh the page 6) Look at the source for that item again. -- It should have <span> tags around the 4 things listed above. 7) Run the koha qa test tools. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> NOTE: Since there was lots of squashing and rebasing, could you please test and sign this off as well, Mason? Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de> Template change only, no regression found. Using [%- -%] could improve readability of HTML source code. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10823 Galen Charlton <gmcharlt@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |gmcharlt@gmail.com --- Comment #20 from Galen Charlton <gmcharlt@gmail.com> --- Pushed to master. Thanks, Mason! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org