[Bug 18187] New: finishreceive.pl: Save bookseller name into items acquisition source field
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Bug ID: 18187 Summary: finishreceive.pl: Save bookseller name into items acquisition source field Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Acquisitions Assignee: koha-bugs@lists.koha-community.org Reporter: m.de.rooy@rijksmuseum.nl QA Contact: testopia@bugs.koha-community.org -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 --- Comment #1 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 60754 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=60754&action=edit Bug 18187: finishreceive.pl: Save bookseller name into items acquisition source field Currently, finishreceive saves the literal booksellerid (a number) into the item text field labeled as "Source of acquisition", unfortunately called booksellerid. (This is the case for AcqCreateItem == receiving.) I opened up another report for renaming this item field (18188). On this report we make finishreceive.pl save the name of the bookseller into the item field. This is more informative. But I could imagine that we need a broader solution: [1] Do we really always want that information in an item? [2] Should orderreceive not put this information in the item field? Now we postpone that to finishreceive; finishreceive just overwrites these fields, completely ignoring what was there. Any feedback is welcome. Test plan: [1] Set AcqCreateItem to receiving. [2] Receive an order. Check 952$e in the resulting item. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |m.de.rooy@rijksmuseum.nl |ity.org | -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |18188 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18188 [Bug 18188] Should we rename items.booksellerid to items.acqsource ? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #2 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I think we do want the information in the item, as some libraries might not keep the acquisitions information forever. A clean solution might be to have a free text field to use manually and a proper booksellerid field. As receiving is the last step, I think overwriting there with the latest vendor makes kind of sense to me. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |BLOCKED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|BLOCKED |RESOLVED Resolution|--- |WONTFIX -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|RESOLVED |CLOSED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18187 Serhij Dubyk <dubyk@ukr.net> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dubyk@ukr.net -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org