Paul POULAIN a écrit :
I've continued to work on Circulation cleaning. - merge overdues and branchoverdues.pl
DONE
- remove department in branchoverdues.pl
DONE
- some $env in API still to remove (updateStats calls mainly)
DONE (everywhere, a huge stuff... partially tested, so excuse any error) still to do :
- fix branchtransfer for reserved items - reintroduce fixaccountforlostandreturned as requested by rosalie - remove getnextacctno, and replace it by an auto_increment field (the code is dirty & dangerous) - AddReturn returns useless informations - Rename Reserves2.pm to Reserves.pm - change some sub name & checking for some subs being 2 for the same goal - change some script names (waitingreservestransfers.pl, currenttransferst.pl, branchreserves.pl) to something more readable.
I hope to work on this tomorrow
I won't work on this anymore this week i'm afraid... -- Paul POULAIN et Henri Damien LAURENT Consultants indépendants en logiciels libres et bibliothéconomie (http://www.koha-fr.org) Tel : 04 91 31 45 19