1/ Import stuffs modules But we could imagine a generic Koha::Exporter|Importer modules with specific Koha::Object[s?]::Export|Import modules. Sounds good to me: If Patron export needs some additional functionality, add Koha::Patron::Export on top of Koha::Exporter.
2/ Move C4::Members::GetBorrowersWithIssuesHistoryOlderThan to the Koha namespace This subroutine is supposed to return the patrons with an issue history older than a given date. Otherwise we could decide to move the subroutine to a method of Koha::OldIssues, to avoid the join. But that sounds weird to me. Agreed. Not very intuitive to put a GetBorrowers... inside OldIssues.
3/ Move C4::Ratings May not understand it fully. But calculate_avg can return the hashref with values ?
4/ Move subroutines not directly related to a Koha::Object In some cases, the move is not very obvious. For instance we have C4::Members::checkcardnumber and C4::Members::get_cardnumber_length, If get_cardnumber_length in Members is not about a patron's cardnumber, maybe we should not keep them together.
5/ patronflags? Separate object ?