7 Sep
2012
7 Sep
'12
1:41 p.m.
Hi Koha-devel, I just pushed t/Members_AttributeTypes.t unit tests that fake the database. The test here could be redundant with t/db_dependent tests I feel we should be aware of that, and : * decide Mock is the way to go, and promote using of Mock, removing db_dependent tests (that fail if you don't have a database) * decide we should prefer db_dependent tests and limit the use of Mock to specific cases I feel that deciding nothing will result in a poor readability of what tests what, and some difficulties to know which test is to update when you update a sub. So, as Mock is introduced, we must speak of it. Your opinion ? -- Paul POULAIN http://www.biblibre.com Expert en Logiciels Libres pour l'info-doc Tel : (33) 4 91 81 35 08