I've continued to work on Circulation cleaning. Here is a list of tests that works atm : * issue book : OK * renew issue from circulation.pl page: OK * renew issue from moremember.pl page : OK * return book : OK * return book : enter unknown barcode: OK * issue book BookA (branch A) to Borr1 (branch A), login as librarian from branch B, reserve book for Borr2 (branch B), delete reserve : OK * Transfering an issued book : - issue book BookA (branch A) to Borr1 (branch A), => OK - login as librarian from branch B, - reserve book for Borr2 (branch B), =>OK - delete reserve, => OK -re-enter reserve again - login as librarian from branch A, - return bookA and confirm transfer to branch B => OK - login as librarian from branch B - check in transfers to recieve that transfer is on the way. => OK - do a return as branch B to validate the transfer => OK * branchreserve.pl (pending reserves for books at a given branch) - cancel a reserve of a book from this branch => OK - cancel a reserve at branch A of a book owned by branch B => OK, (the transfer appears if you look at transfers to recieve at branch B) * Transfers to do (waitingreservestransfers.pl => OK * Transfers to recieve (currenttransferst.pl) => OK * Pending reserves (to pick up in the shelves, reserve.pl) => OK * Reserves waiting for patron pick-up (branchreserves.pl) => OK * overdues (overdues.pl) => OK, see below * overdues by branch (branchoverdues.pl) => OK, see below * (branchtransfer.pl) transfering manually a book => partially. Seems not to work with reserves, but works for "standard" situation, for books issued (=automatic return) TODO : - merge overdues and branchoverdues.pl - remove department in branchoverdues.pl - fix branchtransfer for reserved items - reintroduce fixaccountforlostandreturned as requested by rosalie - remove getnextacctno, and replace it by an auto_increment field (the code is dirty & dangerous) - some $env in API still to remove (updateStats calls mainly) - AddReturn returns useless informations - Rename Reserves2.pm to Reserves.pm - change some sub name & checking for some subs being 2 for the same goal - change some script names (waitingreservestransfers.pl, currenttransferst.pl, branchreserves.pl) to something more readable. I hope to work on this tomorrow Cheers. -- Paul POULAIN et Henri Damien LAURENT Consultants indépendants en logiciels libres et bibliothéconomie (http://www.koha-fr.org) Tel : 04 91 31 45 19