the Acquisition.pm (aka : Catalogue.pm for MARC version) contains too much subs imho. It's hard to read, and not always very coherent : sub addwebsite { sub basket { sub bookfundbreakdown { sub bookfunds { sub bookseller { sub branches { sub breakdown { sub curconvert { sub deletebiblioitem { sub deletewebsite { sub delorder { sub findall { sub getallorders { sub getbiblio { sub getbiblioitem { sub getbiblioitembybiblionumber { sub getcurrencies { sub getcurrency { sub getitemsbybiblioitem { sub getitemtypes { sub getorders { sub getrecorders { sub getsingleorder { sub insertsup { sub invoice { sub isbnsearch { sub modaddauthor { sub modbibitem { sub modbiblio { sub moditem { sub modnote { sub modorder { sub modsubject { sub modsubtitle { sub newbasket { sub newbiblio { sub newbiblioitem { sub newitems { sub neworder { sub newordernum { sub newsubject { sub newsubtitle { sub ordersearch { sub receiveorder { sub updatecurrencies { sub updatesup { sub updatewebsite { sub websitesearch { It contains sub used to administer biblios (addBiblio, addBiblioitem, addItem, modBiblio...) and sub used to administer loans and orders. I propose to divide the script in 2 differents ones. the first would be Biblio.pm (used only for biblio management : biblio/biblioitems/items/additionalauthor/subtitle tables), the second would remain Acquisition.pm (Catalogue.pm for MARC) Is there someone against this idea ? -- Paul