Hello, i'm translating the syspref added this week, and have found some that are only defined, and not used in the code : - WebBasedSelfCheck - staffClientBaseURL - minPasswordLength - noItemTypeImages - noOPACHolds (+ kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive") - emailLibrarianWhenHoldIsPlaced - holdCancelLength - libraryAddress - finesMode (this one is used, but only in C4/SIP/Patron.pm, which is, afaik, specific & not production ready - globalDueDate - itemBarcodeInputFilter - singleBranchMode - URLLinkText - noOPACUserLogin (which would be a duplicate of opacuserlogin iiuc + kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive") - OPACDisplayExtendedSubInfo - OPACViewOthersSuggestions - OPACURLOpenInNewWindow - OPACUserCSS (what does this one mean ? We already have opacstylesheet, opaccolorstylesheet) - emailPurchaseSuggestions There are so many missing that I just checked my repo was uptodate !!! so, were they here by mistake ? it is some planned features ? something i've missed ? cheers -- Paul POULAIN BibLibre SARL Expert en Logiciels Libres pour l'info-doc Tel : 04 91 31 45 19
Hi, On 11/28/07, Paul POULAIN <paul.poulain@free.fr> wrote:
i'm translating the syspref added this week, and have found some that are only defined, and not used in the code :
I've gone through these sysprefs, and think most of them should be removed. Details follow:
- WebBasedSelfCheck
Not used in 3.0 or 2.2.9. But was this intended for use by the scripts in opac/sco?
- staffClientBaseURL
Used by misc/benchmark.pl, so should keep for now.
- minPasswordLength
In use.
- noItemTypeImages
In use, though should rename if we follow the suggestion of using positive names for the sysprefs.
- noOPACHolds (+ kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive")
Not used in 3.0 or 2.2.9. RequestOnOpac appears to serve its purpose.
- emailLibrarianWhenHoldIsPlaced
Not used in 3.0 or 2.2.9.
- holdCancelLength
Not used in 3.0 or 2.2.9.
- libraryAddress
Not used in 3.0 or 2.2.9.
- finesMode (this one is used, but only in C4/SIP/Patron.pm, which is, afaik, specific & not production ready
Should keep if used, but perhaps should be renamed if it is specific to SIP support.
- globalDueDate
Not used in 3.0 or 2.2.9.
- itemBarcodeInputFilter
Not used in 3.0 or 2.2.9.
- singleBranchMode
Not used in 3.0 or 2.2.9.
- URLLinkText
Not used in 3.0 or 2.2.9.
- noOPACUserLogin (which would be a duplicate of opacuserlogin iiuc + kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive")
Not used in 3.0 or 2.2.9, and I agree that this sounds like a duplicate of opacuserlogin.
- OPACDisplayExtendedSubInfo
Not used in 3.0 or 2.2.9.
- OPACViewOthersSuggestions
Not used in 3.0 or 2.2.9.
- OPACURLOpenInNewWindow
Not used in 3.0 or 2.2.9.
- OPACUserCSS (what does this one mean ? We already have opacstylesheet, opaccolorstylesheet)
Not used in 3.0 or 2.2.9.
- emailPurchaseSuggestions
Not used in 3.0 to 2.2.9. To summarize, the following sysprefs are not used by active code: WebBasedSelfCheck noOPACHolds emailLibrarianWhenHoldIsPlaced holdCancelLength libraryAddress globalDueDate itemBarcodeInputFilter singleBranchMode URLLinkText noOPACUserLogin OPACDisplayExtendedSubInfo OPACViewOthersSuggestions OPACURLOpenInNewWindow OPACUserCSS emailPurchaseSuggestions I plan to make a patch later this week to remove these sysprefs. Please let me know if any of these are in fact in use, represent pre-2.2.9 features that ought to be ported to 3.0, represent a feature that someone is willing to code and submit a patch for relatively soon, or are in use by an existing contrib. If there are any other dead sysprefs that should be removed, please post those as well. Regards, Galen -- Galen Charlton Koha Application Developer LibLime galen.charlton@liblime.com p: 1-888-564-2457 x709
On 2/19/08, Galen Charlton <galen.charlton@liblime.com> wrote:
To summarize, the following sysprefs are not used by active code:
WebBasedSelfCheck This should be used to enable/disable the sco/ code in the OPAC, many libraries would view this as a security risk if it were available by default.
noOPACHolds This was designed to remove all of the 'place hold' links in the OPAC, there is working code in dev_week and/or 2.2.9 for this and it needs to be forward-ported, or another solution to accommodate that preference needs to be created.
emailLibrarianWhenHoldIsPlaced There is working code in dev_week (I believe) that utilizes this, it's in use by several libraries and should be retained in 3.0.
holdCancelLength This should be added to the holds matrix when that appears.
libraryAddress I'm not sure why we would need this one, seems like the library address info is available from the branches table.
globalDueDate Some koha libraries running 2.2.9 use this to set the due date globally for all materials and patrons, it should be retained in 3.0.
itemBarcodeInputFilter This was utilized in 2.2.9 and is used by libraries running Koha, perhaps Ryan can clarify exactly it's nature ... I'm assuming it should be retained for 3.0 as well.
singleBranchMode Single Branch Mode is used in 2.2.9 to allow a library to instantly remove all branch choices from searching, holds, etc., since those dropdowns don't make any sense in a library with only one branch. It should definitely be retained for 3.0.
URLLinkText This was used in 2.2.9/dev_week to allow someone to fill in text for every URL that displays in the catalog, generated from a 856 tag. it's used in current Koha systems and should be retained in 3.0, or a better alternative offered.
noOPACUserLogin This disables the OPAC user login and is in active use by koha libraries, should be retained for 3.0.
OPACDisplayExtendedSubInfo This syspref is used for controlling how subscriptsion display in the OPAC, Ryan can expand on the details, but it should either be retained as is, or replaced with something more flexible w/respect to display of subscription information.
OPACViewOthersSuggestions This is a syspref used to enable/disable patrons from seeing suggestions from other patrons, some libraries want patrons to see all suggestions added, others only want the patron's own suggestions to be visible.
OPACURLOpenInNewWindow This controlled whether the 856 links should open in the same window or in a new window in the browser.
OPACUserCSS This syspref allowed a koha sysadmin to add a block of CSS that would be embedded on the OPAC page, which would allow them to take advantage of the cascading effect and override previous CSS settings. It should definitely be retained for 3.0.
emailPurchaseSuggestions This is similar to the 'emailLibrarianWhenHoldIsPlaced' syspref, for when someone makes a purchase suggestion, it will email the librarian.
I plan to make a patch later this week to remove these sysprefs. Please let me know if any of these are in fact in use, represent pre-2.2.9 features that ought to be ported to 3.0, represent a feature that someone is willing to code and submit a patch for relatively soon, or are in use by an existing contrib. If there are any other dead sysprefs that should be removed, please post those as well. In short, most of the sysprefs represent features that should be forward-ported to 3.0, or we'll have some unhappy Koha users :-). Generally speaking, most of them require quite trivial additions; some could definitely be re-factored to be more generally useful.
My two cents. Cheers, -- Joshua Ferraro SUPPORT FOR OPEN-SOURCE SOFTWARE CEO migration, training, maintenance, support LibLime Featuring Koha Open-Source ILS jmf@liblime.com |Full Demos at http://liblime.com/koha |1(888)KohaILS
I plan to make a patch later this week to remove these sysprefs. Please let me know if any of these are in fact in use, represent pre-2.2.9 features that ought to be ported to 3.0, represent a feature that someone is willing to code and submit a patch for relatively soon, or are in use by an existing contrib. If there are any other dead sysprefs that should be removed, please post those as well.
In short, most of the sysprefs represent features that should be forward-ported to 3.0, or we'll have some unhappy Koha users :-). Generally speaking, most of them require quite trivial additions; some could definitely be re- factored to be more generally useful.
Hi All, On a related topic... thats been something ive wanted to improve for a *long* time.... Is it about time that koha-sysprefs area had a better way of grouping related sysprefs together? (FYI: the old koha.v2 syspref-grouping seems to be missing from Koha3 currently?) Perhaps a new 'systempreferences_groups' table, and a new 'group' column added to the existing sysprefs table could work as a quick-fix solution... Then a new syspref-group could be easily created by staff or developers, and new or existing sysprefs could be easily grouped mysql> select * from systempreferences where variable = 'QueryFuzzy'\G *************************** 1. row *************************** variable: QueryFuzzy value: 1 options: NULL explanation: If ON, enables fuzzy option for searches type: YesNo group: zebra_searching <<<<<<<<<<<<<<<<<<<< NEW COLUMN?!??!?!? In Koha.2, the only way to assign a syspref to a group was to edit the sysprefs.pl file Which was too much effort for most people, and consequently lots of sysprefs were added without being assigned to a group. Which has historically lead to a few (misunderstood / broken / duplicated) sysprefs, Any ideas people? Cheers, Mason -- Mason James mason.james@liblime.com Programmer www.liblime.com LibLime +64 21 542 117
On 2/19/08, Joshua Ferraro <jmf@liblime.com> wrote:
On 2/19/08, Galen Charlton <galen.charlton@liblime.com> wrote:
itemBarcodeInputFilter This was utilized in 2.2.9 and is used by libraries running Koha, perhaps Ryan can clarify exactly it's nature ... I'm assuming it should be retained for 3.0 as well. Ryan graciously just added this and I've pushed it up.
Cheers, -- Joshua Ferraro SUPPORT FOR OPEN-SOURCE SOFTWARE CEO migration, training, maintenance, support LibLime Featuring Koha Open-Source ILS jmf@liblime.com |Full Demos at http://liblime.com/koha |1(888)KohaILS
participants (4)
-
Galen Charlton -
Joshua Ferraro -
Mason James -
Paul POULAIN