Hi, On 11/28/07, Paul POULAIN <paul.poulain@free.fr> wrote:
i'm translating the syspref added this week, and have found some that are only defined, and not used in the code :
I've gone through these sysprefs, and think most of them should be removed. Details follow:
- WebBasedSelfCheck
Not used in 3.0 or 2.2.9. But was this intended for use by the scripts in opac/sco?
- staffClientBaseURL
Used by misc/benchmark.pl, so should keep for now.
- minPasswordLength
In use.
- noItemTypeImages
In use, though should rename if we follow the suggestion of using positive names for the sysprefs.
- noOPACHolds (+ kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive")
Not used in 3.0 or 2.2.9. RequestOnOpac appears to serve its purpose.
- emailLibrarianWhenHoldIsPlaced
Not used in 3.0 or 2.2.9.
- holdCancelLength
Not used in 3.0 or 2.2.9.
- libraryAddress
Not used in 3.0 or 2.2.9.
- finesMode (this one is used, but only in C4/SIP/Patron.pm, which is, afaik, specific & not production ready
Should keep if used, but perhaps should be renamed if it is specific to SIP support.
- globalDueDate
Not used in 3.0 or 2.2.9.
- itemBarcodeInputFilter
Not used in 3.0 or 2.2.9.
- singleBranchMode
Not used in 3.0 or 2.2.9.
- URLLinkText
Not used in 3.0 or 2.2.9.
- noOPACUserLogin (which would be a duplicate of opacuserlogin iiuc + kados said, and he was right, that setting "no" to a "noXXXX" parameter means "XXXX", so we should probably rename this syspref to something "positive")
Not used in 3.0 or 2.2.9, and I agree that this sounds like a duplicate of opacuserlogin.
- OPACDisplayExtendedSubInfo
Not used in 3.0 or 2.2.9.
- OPACViewOthersSuggestions
Not used in 3.0 or 2.2.9.
- OPACURLOpenInNewWindow
Not used in 3.0 or 2.2.9.
- OPACUserCSS (what does this one mean ? We already have opacstylesheet, opaccolorstylesheet)
Not used in 3.0 or 2.2.9.
- emailPurchaseSuggestions
Not used in 3.0 to 2.2.9. To summarize, the following sysprefs are not used by active code: WebBasedSelfCheck noOPACHolds emailLibrarianWhenHoldIsPlaced holdCancelLength libraryAddress globalDueDate itemBarcodeInputFilter singleBranchMode URLLinkText noOPACUserLogin OPACDisplayExtendedSubInfo OPACViewOthersSuggestions OPACURLOpenInNewWindow OPACUserCSS emailPurchaseSuggestions I plan to make a patch later this week to remove these sysprefs. Please let me know if any of these are in fact in use, represent pre-2.2.9 features that ought to be ported to 3.0, represent a feature that someone is willing to code and submit a patch for relatively soon, or are in use by an existing contrib. If there are any other dead sysprefs that should be removed, please post those as well. Regards, Galen -- Galen Charlton Koha Application Developer LibLime galen.charlton@liblime.com p: 1-888-564-2457 x709