http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7376 --- Comment #18 from Olli-Antti Kivilahti <olli-antti.kivilahti@jns.fi> --- I think we should make a single function &CheckBranchTransferLimits($item, $biblio, $destinationBranch, $sourceBranch) # either $item or $biblio should be given, preferably both due to # C4::Context->preference("item-level_itypes") Otherwise we get crazy code duplication since the check for BranchTransferLimits is really messy in the calling method. Also this check is performed during circ/branchtransfers.pl and it definetely should be checked when placing reservations/holds as well. Also some Restful API's we have, place holds and they should be UseBranchTransferLimits-capable. Placing holds is beyond the scope of this bug, but now that a patch has been applied I'd prefer to have a central way of checking the UseBranchTransferLimit instead of replicating this code everywhere. -- You are receiving this mail because: You are watching all bug changes.