https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36495 --- Comment #7 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Jonathan Druart from comment #6)
Yes I agree with Martin, we should adjust "Object". I think we shouldn't use the generic "Object" term. For GET /patrons/{patron_id}/holds/{hold_id} we certainly want to see the difference between "Patron not found" and "Hold not found".
I didn't do it right away so we could discuss it on the dev meeting. I agree we should make them specific. Not sure if it would be an issue that we expose the non existence of a (patron?) id this way. But as we are using ->search_limited, that should be covered (i.e. the consumer wouldn't know what makes is 'not exist'). Side note: I picked 'Resource' instead of object for the fallback case :-P. -- You are receiving this mail because: You are watching all bug changes.