https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32991 --- Comment #11 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Matt Blenkinsop from comment #10)
(In reply to Jonathan Druart from comment #6)
Finally, there is something weird in Main.vue we need to fix. The console is showing a warning "[Vue warn]: setup() return property "_is_loading" should not start with "$" or "_" which are reserved prefixes for Vue internals."
This appears to just need a new variable name - Vue won't accept variables prefixed with "_" in root components so "_is_loading" will need renaming. We can't just remove the "_" as there is a getter called "is_loading" and this will conflict. Maybe "content_is_loading"?
Yes, the thing is that Agustin decided to prefix the store variables with '_', to get a good getter method name. We should not only rename is_loading, but others as well (for consistency), and so we need to provide a clean solution for all of them. But first I wanted to make sure the trick in Main was necessary and there was no better alternative. -- You are receiving this mail because: You are watching all bug changes.