http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13941 Frédéric Demians <frederic@tamil.fr> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA --- Comment #25 from Frédéric Demians <frederic@tamil.fr> --- (In reply to Jonathan Druart from comment #24)
Sorry, read to quickly the push statement. I personally think it's a bad idea to assign the default variable, but I don't want to impose that.
I agree with you. Since I have to fix the patch due to you other comment, I will stop using default variable which doesn't add readability in these case.
Without the second patch applied, I get: % prove xt/tt_valid.t xt/tt_valid.t .. Can't use string ("</head>") as a HASH ref while "strict refs" in use at xt/tt_valid.t line 60.
It comes from fixing the warning you reported. I will send new version of the UT.
Shouldn't it fail?
Yes, it should. -- You are receiving this mail because: You are watching all bug changes.