https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22818 --- Comment #182 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Andrew Isherwood from comment #180)
(In reply to Jonathan Druart from comment #162)
Those changes are not expected:
- my $library = Koha::Libraries->find($params->{current_branchcode}) + my $branch = Koha::Libraries->find($params->{current_branchcode})
I'm afraid I don't understand. In this patch https://bugs.koha-community.org/bugzilla3/attachment. cgi?id=113409&action=diff I fixed a misnamed variable, from $library -> $branch, which is the change you've highlighted above. Why is this unexpected?
We prefer "library" over "branch" https://wiki.koha-community.org/wiki/Terminology
2. PATRON_NOTICE is (so far) only for ILL notices, should not we make it explicit on the interface to not cause confusion?
Sorry, I don't understand, make it explicit where in the interface? It's listed, and can be selected, along with all the other log actions in the "Browse the system logs" page. Is this where you are talking about?
On the log viewer, there is a checkbox "Send a notice to a patron" with a code "PATRON_NOTICE". Which implies you will see all the notices sent. But actually we only support 2 notices, the ones you have created. I think this should cover all notices and be moved to a separate bug report. Or we improve the wording... -- You are receiving this mail because: You are watching all bug changes.