https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15774 --- Comment #57 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- (In reply to M. Tompsett from comment #48)
(In reply to Katrin Fischer from comment #46)
I think search_by doesn't sound quite right... search_on? search_in? Native speaker? :)
search_for? I don't like filter_by, because filter_by suggests we are taking a given set and shrinking it. No such thing is passed. We are searching, but it is limited for a particular set of conditions. The rest would describe the condition. And why not just get_by_marc_field (would do tagfield, but tagsubfield is included, I believe), get_by_kohafield?
But you are filtering... you pass in a resultset (whether that be a new one or an existing already partially filtered one) and then refine it by filtering down... We're trying to bring consistency to the objects, so to me filter_by which is already being discussed elsewhere seems to make sense. -- You are receiving this mail because: You are watching all bug changes.