http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7441 --- Comment #39 from Kyle M Hall <kyle.m.hall@gmail.com> ---
* in the 3rd patch, the Koha/Template/Plugin/Koha.pm is improperly named I think, it should be Systempreference.pm or something more meaningful than "Koha".
I think we need a Koha-level TT plugin the same way we have a Koha.pm. It should be a place to put all the once-off plugin logic that does not have multiple functions. If we have a separate TT plugin for each action like this, we will end up with a dozen or more plugins, each of which will need a USE line at the top of each template. That seems unnecessary, doesn't it? [% Koha.Preference( PrefName ) %] seems more clean and sensible than [% KohaPreferences.Preference( PrefName ) %]. If you disagree with my logic here, just reset the status to Failed QA and I will make the requested modifications. -- You are receiving this mail because: You are watching all bug changes.