https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18355 --- Comment #45 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 95880 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=95880&action=edit Bug 18355: (QA follow-up) Rearrange comments, improve code Comments were hard to read (for me) but tastes differ.. Code should reflect that permanent_location is a code and that location may be already an authval. See detail.pl: $item->{'location'} = $shelflocations->{$shelfcode} if ( defined( $shelfcode ) && defined($shelflocations) && exists( $shelflocations->{$shelfcode} ) ); Obviously, this kind of logic divided over two places should be reduced. Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl> -- You are receiving this mail because: You are watching all bug changes.