http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10807 Chris Cormack <chris@bigballofwax.co.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |chris@bigballofwax.co.nz --- Comment #19 from Chris Cormack <chris@bigballofwax.co.nz> --- (In reply to Galen Charlton from comment #18)
(In reply to Jonathan Druart from comment #14)
1) The subs in Search:History.pm don't seem to follow our usual naming conventions. I am a bit unsure about this.
I wasn't aware about this rule. I just see it's in the coding guidelines but I am wondering if it is currently the case. Looking at the Koha namespace a lot of modules don't use the CamelCase notation.
Yeah, we haven't been consistent. I have no strong feelings one way or the other.
Me either, except I think that for a module that isn't OO, get is a bad name for a subroutine. If it were $history->get() I'd be ok with that. But having to fully qualify it Search::History::get() to make it meaningful I think is a bit clumsy. -- You are receiving this mail because: You are watching all bug changes.