https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18856 --- Comment #15 from Barton Chittenden <barton@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #14)
Kyle, Katrin and Marcel, could you take a look at this l ast patch? It sounds better to me to keep the method and fix its behaviour instead of testing is_found that can be confusing. Feel free to obsolete it if you disagree and I will pushed Kyle's patches with a follow-up to remove the method and the tests.
The problem with 'is_cancelable' is that staff and opac have different views of whether the item is cancelable or not, whereas is_found is un-ambiguous. is_cancelable *sounds* like it's clearer because it signals its intent, but under the circumstances, I think 'is_found' is better. Just my humble opinion; I'm also probably missing context because I haven't taken the time to read the code, so take my words with a large grain of salt. -- You are receiving this mail because: You are watching all bug changes.