https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26993 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA --- Comment #26 from Jonathan Druart <jonathan.druart@gmail.com> --- QA comment: 1. I think removing the FK check in the db rev is enough (see previous patch) 2. last_returned_by_all should return a set (not an arrayref), and $self->_result->last_returned_by->delete_all; should be $self->last_returned_by_all->delete; 3. Maybe last_returned_by_all should be renamed last_borrowers? :) 4. (note) There is certainly something to improve in last_returned_by when removing the last X patrons, but I didn't find something that won't remove readability. 5. (not blocker, thought) not sure we should deal with the purge in this method # If StoreLastBorrower is 0 or disabled, bail without storing anything. Also delete any remaining rows from the table. if ( $max_stored_borrowers == 0 ) { $self->_result->last_returned_by->delete_all; return $self; } 6. last_returned_by is not concurrency-safe, but it shouldn't be a problem here. However we should at least use a transaction. -- You are receiving this mail because: You are watching all bug changes.