https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41530 --- Comment #3 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 190924 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=190924&action=edit Bug 41530: Rename item_type => item_type_id in clubs holds API spec Following the API consistency work in bug 41456, this patch renames the item_type field to item_type_id in the clubs holds API endpoint. The field should only be named item_type when it contains an embedded object (type: object/null). When it contains a foreign key ID (type: string/null), it should be named item_type_id for consistency. Changes: - Updated api/v1/swagger/paths/clubs.yaml - Updated Koha::REST::V1::Clubs::Holds to use item_type_id Test plan: 1. Run API tests: prove t/db_dependent/api/v1/clubs_holds.t 2. Verify club holds continue to work correctly 3. Check that item_type_id field is properly mapped in API requests -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.