http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10276 --- Comment #59 from Kyle M Hall <kyle@bywatersolutions.com> ---
1/ There is a lack of unit tests here.
I'll add some.
2/ I don't understand the interest of the stringify param, it's just a 1 line join.
That's cruft from previous versions of the feature. I'll find and remove those.
3/ QA Followup 2 could be squashed with the main patch for the readability.
Will do!
4/ Clone is a new dependency. But that could be avoid. I think something like my $clone = { %$hash_ref }; does the same think. I'll take a look at that.
5/ How to be sure your changes are exhaustive? Everywhere IndependentBranches is used, that's it?
Yep! -- You are receiving this mail because: You are watching all bug changes.