http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10807 --- Comment #21 from Jonathan Druart <jonathan.druart@biblibre.com> --- (In reply to Galen Charlton from comment #20)
(In reply to Chris Cormack from comment #19)
Me either, except I think that for a module that isn't OO, get is a bad name for a subroutine.
If it were $history->get() I'd be ok with that. But having to fully qualify it Search::History::get() to make it meaningful I think is a bit clumsy.
Indeed, although a fully-qualified Search::History::get() might be better than optionally exporting a GetSearchHistory().
But I think we're more or less on the same page -- best of all would be turning it into a class, and I think that could be done with only a small effort.
Hello Chris and Galen, I created the module in the C4 namespace precisely because it is not a OO module. There are some doubt (at least for me) about how to create a new module into Koha: Dbix will arrive shortly (or not), Moo, Class::Accessor, etc. The last time I thought I created a correct module (bug 10363), the patch has been ejected in the discussion status. With this patch, I simply tried to group search history code into a module in order to re-use it somewhere else (bug 10862). -- You are receiving this mail because: You are watching all bug changes.