http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10807 --- Comment #20 from Galen Charlton <gmcharlt@gmail.com> --- (In reply to Chris Cormack from comment #19)
Me either, except I think that for a module that isn't OO, get is a bad name for a subroutine.
If it were $history->get() I'd be ok with that. But having to fully qualify it Search::History::get() to make it meaningful I think is a bit clumsy.
Indeed, although a fully-qualified Search::History::get() might be better than optionally exporting a GetSearchHistory(). But I think we're more or less on the same page -- best of all would be turning it into a class, and I think that could be done with only a small effort. -- You are receiving this mail because: You are watching all bug changes.