https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37054 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Failed QA --- Comment #34 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Laura Escamilla from comment #33)
Thank you for working on this, Lucas! I'm so excited to see this in Koha.
Hi Laura, thanks for QA! As we are just at the beginning of the cycle I'll be more strict about the guidelines for QA/SO being from people of different institutions. Sorry that this "hit you" first now :( I'd also like to get some notes on implementation. We now have opacusercss in the branches table. This is for adjusting the color in one specific spot, which could also have been achieved with a staffusercss. Is there a strong reason it was done this way? (I assume so, but always good to have it written down!) Some notes from looking at the code: 1) This uses "branch" a lot, but library should be used. https://wiki.koha-community.org/wiki/Terminology 2) I believe we are missing changes for the REST API since there are routes for library information. If this was named library_color in the db as well, we could save a mapping. 3) I think the method name should be snake case per PERL9: Subroutine naming conventions. https://wiki.koha-community.org/wiki/Coding_Guidelines -- You are receiving this mail because: You are watching all bug changes.