https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37054 --- Comment #54 from David Cook <dcook@prosentient.com.au> --- (In reply to Lucas Gass (lukeg) from comment #52)
(In reply to David Cook from comment #48)
(In reply to David Cook from comment #47)
Further, how cool would it be to have a colour palette that could be configured by a web administrator?
That said, all the ideas here could conflict with bug 38550
I should state what the original purpose of this bug was. We have many consortium that want each individual branch to have a different color header, replacing the original green. This is a way for librarians and administrators to quickly differentiate which branch they are logged into.
I was doing this with custom JS and I don't want to continue to use JS. I am also not keen on a CSS solution, not everyone wants to write CSS.
(In reply to Lucas Gass (lukeg) from comment #53)
Honestly, "branchcolor/library_color" as a database column feels wrong to me, but... on the right track.
Do you mean the name is wrong? Or the fact that it is a DB column?
Yeah nah, I like your idea. It sounds useful and that it would make for a nice UX. But from a big picture perspective I think it's probably the beginning of something bigger. So yeah the name doesn't feel right, and also I'm not sure about it as a DB column in the "branches" table. It seems to me that there's a lot of room for this to grow, so that in the future "library_color" would need to be renamed (like Katrin's suggestion of staff_header_color). And then if we added things like "staff_font_color" or "staff_bg_color", I think the columns could grow a lot, and they're not really describing the "branch" entity/resource, right? So then I'm thinking of a DB table like "ui_staff" where these "staff_header_color" and "staff_bg_color" are either text columns OR they're object keys in a JSON column. -- But... I think you could argue that a new DB table might be premature since right now you're only proposing 1 new column. Fair enough. But yeah I think a rename to staff_header_color might be a good idea - unless you do see "library_color" being re-used for other sections as well, but... I suspect most libraries/orgs will have a palette of at least 3-5 different colours for a variety of different UI components. So making the DB column name more specific probably makes sense. -- You are receiving this mail because: You are watching all bug changes.