https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19066 --- Comment #18 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to M. Tompsett from comment #17)
Comment on attachment 73186 [details] [review] Bug 19066 - Add branchcode to accountlines
Review of attachment 73186 [details] [review]: -----------------------------------------------------------------
::: Koha/Account.pm @@ +76,4 @@
my $account_type = $params->{account_type}; my $offset_type = $params->{offset_type} || $type eq 'writeoff' ? 'Writeoff' : 'Payment';
+ $library_id ||= C4::Context->userenv ? C4::Context->userenv->{'branch'} : undef;
why not below the $userenv below? Less referencing, shorter line, and easier to read. :)
I'm not sure what you are referencing? Can you point me to the line numbers? Or if you'd rather submit a patch I'd be happy to sign it! -- You are receiving this mail because: You are watching all bug changes.