https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20817 --- Comment #122 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 142647 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=142647&action=edit Bug 20817: Squashed follow-ups * Move subroutines to a new Perl module * Add unit tests * Rename get_infos_syspref_on_item to GetMarcItemFieldsToOrderValues * Rename get_infos_syspref to GetMarcFieldsToOrderValues * Remove syspref from parameters, it is invariant * Fix QA script issues * Update module to use YAML::XS * _trim should always return a value * (QA follow-up) Fix 'undefined subroutine' error * Fix incorrect namespace for subroutine call * Import C4::Items::PrepareItemrecordDisplay for neworderempty.pl * (QA follow-up) Add new parameter for PrepareItemrecordDisplay * (QA follow-up) Fix POD for GetMarcFieldsToOrderValues and GetMarcItemFieldsToOrderValues -- You are receiving this mail because: You are watching all bug changes.