https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20388 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org Status|Passed QA |Failed QA --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- 1. What's the point of the JS function valid_line? I think you should double-check it, it does not do what you expect it to do. 2. You are reusing code to duplicate a new mapping but for something else. You should rename the variables to avoid confusion then. For instance "search_fields" is not an index name 3. Bug report's title is wrong, we are not adding/removing indices 4. I did not implement that part on the original patch because it's hard to keep an interface consistent. For instance: - create a new search field => You cannot create a new mapping, you have to save first - create a new search field, save => You can delete it. So it you create a mapping using it, you can still delete it. If you save => kaboom => If you have a search field already mapped and delete the mapping, you cannot delete the search field. -- You are receiving this mail because: You are watching all bug changes.