[Bug 14464] New: Add ability to cancel waiting holds from checkin screen
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Bug ID: 14464 Summary: Add ability to cancel waiting holds from checkin screen Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Hold requests Assignee: koha-bugs@lists.koha-community.org Reporter: jweaver@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com It should be possible to manually cancel a waiting hold from the returns screen, and add the fine for an expired hold (if configured). -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |jweaver@bywatersolutions.co |ity.org |m -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #1 from Jesse Weaver <jweaver@bywatersolutions.com> --- Created attachment 40697 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40697&action=edit Bug 14464 - Add ability to cancel waiting holds from checkin screen Test plan: 1. Ensure that ExpireReservesMaxPickUpDelayCharge is set to 0. 2. Place a hold (doesn't matter whether it's a bib/item-level hold), then confirm the hold by checking it in. 3. Check in the item again, and hit Cancel. 4. The reserve in question should be cancelled. 5. Repeat steps 2-4 twice, once after setting ExpireReservesMaxPickUpDelayCharge to a nonzero value and again after clicking the "Forgive fees for manually expired holds" checkbox. A fine should only be applied when the syspref is enabled and the checkbox is not checked. Also, the checkbox should only appear after enabling the syspref. And finally, the checkbox should remember whether it is checked across multiple checkins, same as the "Forgive overdue charges" and "Book drop mode" checkboxes. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #40697|0 |1 is obsolete| | --- Comment #2 from Jesse Weaver <jweaver@bywatersolutions.com> --- Created attachment 40752 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40752&action=edit Bug 14464 - Add ability to cancel waiting holds from checkin screen Test plan: 1. Ensure that ExpireReservesMaxPickUpDelayCharge is set to 0. 2. Place a hold (doesn't matter whether it's a bib/item-level hold), then confirm the hold by checking it in. 3. Check in the item again, and hit Cancel. 4. The reserve in question should be cancelled. 5. Repeat steps 2-4 twice, once after setting ExpireReservesMaxPickUpDelayCharge to a nonzero value and again after clicking the "Forgive fees for manually expired holds" checkbox. A fine should only be applied when the syspref is enabled and the checkbox is not checked. Also, the checkbox should only appear after enabling the syspref. And finally, the checkbox should remember whether it is checked across multiple checkins, same as the "Forgive overdue charges" and "Book drop mode" checkboxes. Signed-off-by: Jason Burds <jburds@dubuque.lib.ia.us> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@biblibre.co | |m Status|Signed Off |Failed QA --- Comment #3 from Jonathan Druart <jonathan.druart@biblibre.com> --- Jesse, You have to provide tests for changes in subroutines. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jesse Weaver <jweaver@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #4 from Jesse Weaver <jweaver@bywatersolutions.com> --- Created attachment 40828 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40828&action=edit Bug 14464 - (QA followup) add unit tests This followup adds several tests to t/db_dependent/Reserves.t. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #5 from Jonathan Druart <jonathan.druart@biblibre.com> --- Comment on attachment 40752 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40752 Bug 14464 - Add ability to cancel waiting holds from checkin screen Review of attachment 40752: --> (http://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=14464&attachment=40752) ----------------------------------------------------------------- ::: circ/returns.pl @@ +30,5 @@
use strict; use warnings;
+use Carp 'verbose'; +$SIG{ __DIE__ } = sub { Carp::confess( @_ ) };
Why do you need that? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #6 from Jesse Weaver <jweaver@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #5)
Comment on attachment 40752 [details] [review] Bug 14464 - Add ability to cancel waiting holds from checkin screen
Review of attachment 40752 [details] [review]: -----------------------------------------------------------------
::: circ/returns.pl @@ +30,5 @@
use strict; use warnings;
+use Carp 'verbose'; +$SIG{ __DIE__ } = sub { Carp::confess( @_ ) };
Why do you need that?
... because I forgot to remove some debugging code, apologies. That's safe to remove. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #40752|0 |1 is obsolete| | Attachment #40828|0 |1 is obsolete| | --- Comment #7 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 40896 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40896&action=edit Bug 14464 - Add ability to cancel waiting holds from checkin screen Test plan: 1. Ensure that ExpireReservesMaxPickUpDelayCharge is set to 0. 2. Place a hold (doesn't matter whether it's a bib/item-level hold), then confirm the hold by checking it in. 3. Check in the item again, and hit Cancel. 4. The reserve in question should be cancelled. 5. Repeat steps 2-4 twice, once after setting ExpireReservesMaxPickUpDelayCharge to a nonzero value and again after clicking the "Forgive fees for manually expired holds" checkbox. A fine should only be applied when the syspref is enabled and the checkbox is not checked. Also, the checkbox should only appear after enabling the syspref. And finally, the checkbox should remember whether it is checked across multiple checkins, same as the "Forgive overdue charges" and "Book drop mode" checkboxes. Signed-off-by: Jason Burds <jburds@dubuque.lib.ia.us> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> Amended patch: Removed 2 debugging lines. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #8 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 40897 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=40897&action=edit Bug 14464 - (QA followup) add unit tests This followup adds several tests to t/db_dependent/Reserves.t. Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |tomascohen@gmail.com Status|Passed QA |Pushed to Master --- Comment #9 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Patches pushed to master. Thanks Jesse! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Heather Braum <hbraum@nekls.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |hbraum@nekls.org -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de See Also| |http://bugs.koha-community. | |org/bugzilla3/show_bug.cgi? | |id=14801 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |14137 Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14137 [Bug 14137] Allow ExpireReservesMaxPickUpDelayCharge to be used without ExpireReservesMaxPickUpDelay -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks|14137 | Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14137 [Bug 14137] Allow ExpireReservesMaxPickUpDelayCharge to be used without ExpireReservesMaxPickUpDelay -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- We just started testing the new features of 3.22 and didn't understand that "cancel" meant cancelling the hold, as cancel usually means "do nothing". I filed bug 15670 to suggest renaming the button to the more explicit "Cancel hold" - especially since it will ease translation (abbrechen vs. stornieren in German). -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14464 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |15670 Referenced Bugs: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15670 [Bug 15670] Rename "Cancel" to "Cancel hold" when checking in a waiting item -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org