[Bug 11237] New: Clarify explanation for the new pref AcqItemSetSubfieldsWhenReceived
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Bug ID: 11237 Summary: Clarify explanation for the new pref AcqItemSetSubfieldsWhenReceived Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Acquisitions Assignee: koha-bugs@lists.koha-community.org Reporter: jonathan.druart@biblibre.com QA Contact: testopia@bugs.koha-community.org The explanation for the pref AcqItemSetSubfieldsWhenReceived (introduced by bug 8307) is wrong. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED Depends on| |8307 Assignee|koha-bugs@lists.koha-commun |jonathan.druart@biblibre.co |ity.org |m -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff Patch complexity|--- |String patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #1 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 22868 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=22868&action=edit Bug 11237: Update explanation for pref AcqItemSetSubfieldsWhenReceived Test plan: Update the updatedb entry and search the pref in the admin module. The explanation should have been updated. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on|8307 | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mtompset@hotmail.com --- Comment #2 from M. Tompsett <mtompset@hotmail.com> --- To be honest, I'm confused by the description. I'm a non-librarian. So there is order entry and order receiving, right? When do these fields get set? I didn't go read the code. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #3 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- When items are created on order (AcqCreateItem = on order) the subfields of those items will be updated as set in this preference automatically during the receive process. For example this will allow to remove the 'on order' status. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #4 from M. Tompsett <mtompset@hotmail.com> --- Could I ask that the second when be changed? having two whens in the sentence makes it hard to read. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #5 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Neither Jonathan nor I are native speakers - maybe just make a suggestion what would sound better to you? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #6 from M. Tompsett <mtompset@hotmail.com> --- How about? Upon receiving items, update their subfields if they were created when placing an order (e.g. 995\$o=5) Does this make sense? I intentionally chose "placing an order", because that is the value in the drop down for the AcqCreateItem system preference above it. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #22868|0 |1 is obsolete| | --- Comment #7 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 24376 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24376&action=edit Bug 11237: Update explanation for pref AcqItemSetSubfieldsWhenReceived Test plan: Update the updatedb entry and search the pref in the admin module. The explanation should have been updated. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #8 from M. Tompsett <mtompset@hotmail.com> --- Two things I noticed when I tested. 1) The order of the system preference text box was changed. I don't think that is problem, but felt I should note that. 2) I noticed the default was 0. Should it be 0, or should it be blank? Since this is really outside the scope of updating the explanation, I'm ignoring it, even if it is a potential problem. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off Patch complexity|String patch |Small patch -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #24376|0 |1 is obsolete| | --- Comment #9 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 24410 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24410&action=edit [SIGNED OFF] Bug 11237: Update explanation for pref AcqItemSetSubfieldsWhenReceived Test plan: Update the updatedb entry and search the pref in the admin module. The explanation should have been updated. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA CC| |m.de.rooy@rijksmuseum.nl --- Comment #10 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to M. Tompsett from comment #8)
Two things I noticed when I tested. 1) The order of the system preference text box was changed. I don't think that is problem, but felt I should note that.
Just looking at the patch, I do not understand your remark.
2) I noticed the default was 0. Should it be 0, or should it be blank? Since this is really outside the scope of updating the explanation, I'm ignoring it, even if it is a potential problem.
I agree that it should be blank. In the code I see a split on this pref without further testing. (May not harm, but correcting it is better.) Although you formally could say that it is actually outside report scope, I would like to ask Jonathan to just handle this tiny 'bug' within the same db revision (in the same update statement). No need to touch the same code in two reports. For this reason setting it to Failed QA. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #11 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 24451 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24451&action=edit Bug 11237: Update default value for pref AcqItemSetSubfieldsWhenReceived The default value for this pref should be an empty string, not "0". -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #12 from Jonathan Druart <jonathan.druart@biblibre.com> --- (In reply to M. de Rooy from comment #10)
(In reply to M. Tompsett from comment #8)
Two things I noticed when I tested. 1) The order of the system preference text box was changed. I don't think that is problem, but felt I should note that.
Just looking at the patch, I do not understand your remark.
Before the patch, it was <input> pref description Now it is: pref description <input> I thought it is better but maybe i am wrong. Feel free to change the order if you disagree.
I agree that it should be blank. In the code I see a split on this pref without further testing. (May not harm, but correcting it is better.) Although you formally could say that it is actually outside report scope, I would like to ask Jonathan to just handle this tiny 'bug' within the same db revision (in the same update statement). No need to touch the same code in two reports.
Done! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #13 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Jonathan Druart from comment #12)
Before the patch, it was <input> pref description Now it is: pref description <input> I thought it is better but maybe i am wrong. Feel free to change the order if you disagree. I agree.
I agree that it should be blank. In the code I see a split on this pref without further testing. (May not harm, but correcting it is better.) Although you formally could say that it is actually outside report scope, I would like to ask Jonathan to just handle this tiny 'bug' within the same db revision (in the same update statement). No need to touch the same code in two reports.
Done!
Thanks. If Mark would be willing to sign off on the follow-up, I will finish the QA step. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #14 from M. Tompsett <mtompset@hotmail.com> --- (In reply to M. de Rooy from comment #10)
(In reply to M. Tompsett from comment #8)
Two things I noticed when I tested. 1) The order of the system preference text box was changed. I don't think that is problem, but felt I should note that.
Just looking at the patch, I do not understand your remark.
In the koha-tmpl/intranet-tmpl/prog/en/modules/admin/preferences/acquisitions.pref diff the "pref" line comes before the description initially, and after in the patch. This does not break functionality, but it does change the way it displays in the Acquisition system preferences. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 --- Comment #15 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to M. Tompsett from comment #14)
(In reply to M. de Rooy from comment #10)
(In reply to M. Tompsett from comment #8)
Two things I noticed when I tested. 1) The order of the system preference text box was changed. I don't think that is problem, but felt I should note that.
Just looking at the patch, I do not understand your remark.
In the koha-tmpl/intranet-tmpl/prog/en/modules/admin/preferences/acquisitions.pref diff the "pref" line comes before the description initially, and after in the patch. This does not break functionality, but it does change the way it displays in the Acquisition system preferences.
Thanks for clarification, Mark. Could you sign the follow-up? -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 M. Tompsett <mtompset@hotmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #24451|0 |1 is obsolete| | --- Comment #16 from M. Tompsett <mtompset@hotmail.com> --- Created attachment 24469 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24469&action=edit [SIGNED OFF] Bug 11237: Update default value for pref AcqItemSetSubfieldsWhenReceived The default value for this pref should be an empty string, not "0". Signed-off-by: Mark Tompsett <mtompset@hotmail.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #24410|0 |1 is obsolete| | --- Comment #17 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 24493 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24493&action=edit Bug 11237: Update explanation for pref AcqItemSetSubfieldsWhenReceived Test plan: Update the updatedb entry and search the pref in the admin module. The explanation should have been updated. Signed-off-by: Mark Tompsett <mtompset@hotmail.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #24469|0 |1 is obsolete| | --- Comment #18 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 24494 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=24494&action=edit Bug 11237: Update default value for pref AcqItemSetSubfieldsWhenReceived The default value for this pref should be an empty string, not "0". Signed-off-by: Mark Tompsett <mtompset@hotmail.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA CC| |kyle@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Galen Charlton <gmcharlt@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |gmcharlt@gmail.com --- Comment #19 from Galen Charlton <gmcharlt@gmail.com> --- Pushed to master. Thanks, Jonathan! -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11237 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |mathsabypro@gmail.com --- Comment #20 from Jonathan Druart <jonathan.druart@biblibre.com> --- *** Bug 11323 has been marked as a duplicate of this bug. *** -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org