[Bug 17353] New: Add phone number column to checkout search
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Bug ID: 17353 Summary: Add phone number column to checkout search Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Circulation Assignee: koha-bugs@lists.koha-community.org Reporter: nick@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com, kyle.m.hall@gmail.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Assignee|koha-bugs@lists.koha-commun |nick@bywatersolutions.com |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 --- Comment #1 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 55824 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=55824&action=edit Bug 17353 - Add phone number column to checkout search This patch adds borrowers.phone as 'Primary phone' in the checkout search results. To test: 1 - Perform a checkout search 2 - Note phone is not displayed 3 - Apply patch 4 - Note phone displays 5 - Ensure page functions as before patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #55824|0 |1 is obsolete| | --- Comment #2 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 55831 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=55831&action=edit Bug 17353 - Add phone number column to checkout search This patch adds borrowers.phone as 'Primary phone' in the checkout search results. To test: 1 - Perform a checkout search 2 - Note phone is not displayed 3 - Apply patch 4 - Note phone displays 5 - Ensure page functions as before patch Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |josef.moravec@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #3 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Is it a very useful information to show for everybody? Would not it better to hide it by default (and use the columns configuration tool)? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I like the idea of using the Columns Configuration tool here. I also wondered about the phone number displaying here - can you explain why the library/libraries have asked for it? I notice we don't show the phone number in the more verbose patron search. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |In Discussion -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #55831|0 |1 is obsolete| | --- Comment #5 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 83720 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83720&action=edit Bug 17353 - Add phone number column to checkout search This patch adds borrowers.phone as 'Primary phone' in the checkout search results. It also ads the table to columns configuration To test: 1 - Perform a checkout search 2 - Note phone is not displayed 3 - Apply patch 4 - Note phone does not display 5 - Visit columns configuration 6 - Unhide the 'phone' column 7 - Note phone displays 8 - Ensure page functions as before patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #83720|0 |1 is obsolete| | --- Comment #6 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 83743 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83743&action=edit Bug 17353: Add phone number column to checkout search This patch adds borrowers.phone as 'Primary phone' in the checkout search results. It also ads the table to columns configuration To test: 1 - Perform a checkout search 2 - Note phone is not displayed 3 - Apply patch 4 - Note phone does not display 5 - Visit columns configuration 6 - Unhide the 'phone' column 7 - Note phone displays 8 - Ensure page functions as before patch Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 --- Comment #7 from Nick Clemens <nick@bywatersolutions.com> --- Created attachment 83775 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83775&action=edit Bug 17353: (follow-up) Adjust config variable for moremember.tt too -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Small favor: can we please use a clearer name for the table, that is consistent with the others? This uses: table_borrowers. Most use *-table and hyphens. Also... patron vs. borrower. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #83743|0 |1 is obsolete| | --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 83858 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83858&action=edit Bug 17353: Add phone number column to checkout search This patch adds borrowers.phone as 'Primary phone' in the checkout search results. It also ads the table to columns configuration To test: 1 - Perform a checkout search 2 - Note phone is not displayed 3 - Apply patch 4 - Note phone does not display 5 - Visit columns configuration 6 - Unhide the 'phone' column 7 - Note phone displays 8 - Ensure page functions as before patch Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #83775|0 |1 is obsolete| | --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 83859 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=83859&action=edit Bug 17353: (follow-up) Adjust config variable for moremember.tt too Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|Trivial patch |Small patch --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- see comment 8 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |22215 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22215 [Bug 22215] table_borrowers name is inconsistent with other tables -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #12 from Nick Clemens <nick@bywatersolutions.com> --- Awesome work all! Pushed to master for 19.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED Resolution|--- |FIXED CC| |martin.renvoize@ptfs-europe | |.com --- Comment #13 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Enhancement, will not be backported to 18.11.x series. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |This enhancement adds release notes| |patrons phone numbers to | |the checkout search | |results. It is hidden by | |default and is displayed by | |configuring the columns for | |circulation tables | |(Administration > | |Additional parameters > | |Configure columns > | |Circulation > | |table_borrowers > untick | |the phone column). CC| |david@davidnind.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |30068 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30068 [Bug 30068] Wrong reference to table_borrowers in circulation.tt -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17353 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=36614 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org