[Bug 36596] New: Opening/closing hours should be forced to be set together
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 Bug ID: 36596 Summary: Opening/closing hours should be forced to be set together Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: normal Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: tomascohen@gmail.com QA Contact: testopia@bugs.koha-community.org It only seems to make sense to set a closing hour if an opening hour has been set, otherwise it would be open 24 hs :-D A method needs to be added to Koha::Library: * set_hours( $dow, $opening, $closing ) * The method needs to throw an exception if one of them is not passed * If none is passed then it means the library would not be open, and then all hours for the * The code for setting the hours in branches.pl should be removed and this method used instead * The method MUST BE COVERED BY TESTS NOTE: I don't personally like the chosen column name 'day'. I would use either 'dow' or 'day_of_week'. And it should be clear which one is the first in the comments. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |6796 CC| |tomascohen@gmail.com Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6796 [Bug 6796] Overnight checkouts taking into account opening and closing hours -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Whilst I agree about the column name and the requirement to set both openening and closing.. I'm not so sure about the meaning of no opening/closing.. that could just mean it's a 24h library and open the whole day rather than having an opening/closing time right? -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- We're back into naming consistency territory here.. in repeatable_holidays it's:
`weekday` smallint(6) DEFAULT NULL COMMENT 'day of the week (0=Sunday, 1=Monday, etc) this closing is repeated on'
-- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 Bug 36596 depends on bug 6796, which changed state. Bug 6796 Summary: Overnight checkouts taking into account opening and closing hours https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6796 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- What about 24h libraries.. in those cases you'll want to open one day and close another so you wouldn't necessarily want to be forced to put both opening and closing times in at the same input. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36596 Irene <i.tortorella@arts.ac.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |i.tortorella@arts.ac.uk -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org