[Bug 21791] New: Add payment type on Cash register report (cash_register_stats.pl)
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Bug ID: 21791 Summary: Add payment type on Cash register report (cash_register_stats.pl) Change sponsored?: --- Product: Koha Version: 18.05 Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Reports Assignee: koha-bugs@lists.koha-community.org Reporter: marjorie.barry-vila@collecto.ca QA Contact: testopia@bugs.koha-community.org Hi, Tested on 18.05.03, payment type (see bz 18786) are not display on cash register statistics (cash_register_stats.pl). Regards Marjorie -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Patrick Robitaille <patrick.robitaille@collecto.ca> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |patrick.robitaille@collecto | |.ca -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=18786 CC| |martin.renvoize@ptfs-europe | |.com -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |18786 See Also|https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=18786 | Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18786 [Bug 18786] Add ability to create custom payment types -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=13985 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #1 from Marjorie Barry-Vila <marjorie.barry-vila@collecto.ca> --- +1 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 Eric Phetteplace <ephetteplace@cca.edu> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |ephetteplace@cca.edu -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #2 from Eric Phetteplace <ephetteplace@cca.edu> --- Created attachment 98104 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=98104&action=edit UNTESTED patch -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #3 from Eric Phetteplace <ephetteplace@cca.edu> --- I took a pass at adding this field but I'm not sure if it will work; I didn't test on a sandbox instance. One question I had: the values of accountlines.payment_type come from the PAYMENT_TYPE authorized values. Should the report show the field's literal value (the code) or its (more readable) associated Description? I lean towards showing literal values as they tend to be more consistent over time but I'm not sure if there's a standardized approach for Koha. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- I would say for an inbuilt report like this one then translating codes to descriptions is the preferred approach.. however this is a great start. Just to note, however, I am currently considering a patch to merge payment_type into credit_types as I'm not sure that having two levels of 'type' makes sense now that we have a clearer distinction between 'credit' and 'debit' lines. I'd be interested in feedback for that approach.. are there really times when one would want `pay` + `cash` or `credit` + `beans` vs just having `cash`, `card` and `beans` as a top-level credit type? -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #5 from Eric Phetteplace <ephetteplace@cca.edu> --- Ah OK I will hold off working on this then. For what it's worth, I agree that the payment type/credit type setup seems redundant, but I'll ask our staff what they think about it, too. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21791 --- Comment #6 from Patrick Robitaille <patrick.robitaille@collecto.ca> --- +1 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org