[Bug 38311] New: DataTables - Simplify the building of the dropdown list filters
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Bug ID: 38311 Summary: DataTables - Simplify the building of the dropdown list filters Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: jonathan.druart@gmail.com QA Contact: testopia@bugs.koha-community.org Depends on: 36640 See "Bug 36640: Fix itemsearch", there is a lot of duplicated code to build the select nodes. We should refactor and simplify this code. Same on the item list of the bib detail page. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36640 [Bug 36640] Upgrade DataTables from 1.13.6 to 2.x -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |jonathan.druart@gmail.com |ity.org | Status|NEW |ASSIGNED -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Bug 38311 depends on bug 36640, which changed state. Bug 36640 Summary: Upgrade DataTables from 1.13.6 to 2.x https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=36640 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |40565, 38201 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38201 [Bug 38201] VueJS architecture rethink https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=40565 [Bug 40565] Column filters on the item search do not work -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #1 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 184926 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=184926&action=edit Bug 38311: Do not use ID for column filters -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #2 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 184927 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=184927&action=edit Bug 38311: wip Vue -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #184927|0 |1 is obsolete| | --- Comment #3 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 186209 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=186209&action=edit Bug 38311: Add dropdown list to column filters linked to an AV - Vue components -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |BLOCKED --- Comment #4 from Jonathan Druart <jonathan.druart@gmail.com> --- This is ready for blocked by parent bugs. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #5 from Jonathan Druart <jonathan.druart@gmail.com> --- This is ready but blocked by parent bugs. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |matt.blenkinsop@openfifth.c | |o.uk, | |pedro.amorim@openfifth.co.u | |k -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |blawlor@clamsnet.org -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |40709 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=40709 [Bug 40709] Status filter will display in wrong column if item-level_itypes is set to bibliographic record -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|BLOCKED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #184926|0 |1 is obsolete| | Attachment #186209|0 |1 is obsolete| | --- Comment #6 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 187376 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=187376&action=edit Bug 38311: Do not use ID for column filters -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #7 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 187377 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=187377&action=edit Bug 38311: Add dropdown list to column filters linked to an AV - Vue components -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |oleonard@myacpl.org, | |paul.derscheid@lmscloud.de --- Comment #8 from Jonathan Druart <jonathan.druart@gmail.com> --- This is now ready for testing. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #9 from Jonathan Druart <jonathan.druart@gmail.com> --- This is an easy one, it removes a bad pattern and improves the readability of the code. Can we get a signoff please? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #187377|0 |1 is obsolete| | --- Comment #10 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 188314 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188314&action=edit Bug 38311: Add dropdown list to column filters linked to an AV - Vue components -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #187376|0 |1 is obsolete| | Attachment #188314|0 |1 is obsolete| | --- Comment #11 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 188468 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188468&action=edit Bug 38311: Do not use ID for column filters Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #12 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 188469 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188469&action=edit Bug 38311: Add dropdown list to column filters linked to an AV - Vue components Signed-off-by: Owen Leonard <oleonard@myacpl.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #13 from Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> --- Comment on attachment 188468 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188468 Bug 38311: Do not use ID for column filters Review of attachment 188468: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=38311&attachment=188468) ----------------------------------------------------------------- ::: koha-tmpl/intranet-tmpl/prog/en/modules/circ/pendingbookings.tt @@ +159,5 @@
e['_str'] = e.branchname; return e; }); let filters_options = { + libraries: all_libraries,
Are we missing a dataFilter in a column definition here? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |matt.blenkinsop@openfifth.c |y.org |o.uk -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #14 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 188924 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=188924&action=edit Bug 38311: Fix 'Bookings to collect'/pendingbookings it was missing the dataFilter. Also needs coded_values to work correctly (which needs to be defined outside of document.ready). -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #15 from Jonathan Druart <jonathan.druart@gmail.com> --- (In reply to Matt Blenkinsop from comment #13)
Comment on attachment 188468 [details] [review] Bug 38311: Do not use ID for column filters
Review of attachment 188468 [details] [review]: -----------------------------------------------------------------
::: koha-tmpl/intranet-tmpl/prog/en/modules/circ/pendingbookings.tt @@ +159,5 @@
e['_str'] = e.branchname; return e; }); let filters_options = { + libraries: all_libraries,
Are we missing a dataFilter in a column definition here?
Yes, good catch, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #188468|0 |1 is obsolete| | --- Comment #16 from Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> --- Created attachment 189184 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=189184&action=edit Bug 38311: Do not use ID for column filters Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #188469|0 |1 is obsolete| | --- Comment #17 from Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> --- Created attachment 189185 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=189185&action=edit Bug 38311: Add dropdown list to column filters linked to an AV - Vue components Signed-off-by: Owen Leonard <oleonard@myacpl.org> Signed-off-by: Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #188924|0 |1 is obsolete| | --- Comment #18 from Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> --- Created attachment 189186 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=189186&action=edit Bug 38311: Fix 'Bookings to collect'/pendingbookings it was missing the dataFilter. Also needs coded_values to work correctly (which needs to be defined outside of document.ready). Signed-off-by: Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Lucas Gass (lukeg) <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to main Version(s)| |25.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #19 from Lucas Gass (lukeg) <lucas@bywatersolutions.com> --- Nice work everyone! Pushed to main for 25.11 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 --- Comment #20 from Jonathan Druart <jonathan.druart@gmail.com> --- Created attachment 190071 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=190071&action=edit Bug 38311: Fix Selenium and Cypress tests .dt-select-filter does no longer exist Here we rely on DT's API to retrieve the correct visible column index. However we cannot for Selenium tests, not ideal but it fixes the failure. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |additional_work_needed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Lucas Gass (lukeg) <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|additional_work_needed | CC| |lucas@bywatersolutions.com --- Comment #21 from Lucas Gass (lukeg) <lucas@bywatersolutions.com> --- follow-up pushed to main -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Laura Escamilla <Laura.escamilla@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |Laura.escamilla@bywatersolu | |tions.com Status|Pushed to main |Needs documenting --- Comment #22 from Laura Escamilla <Laura.escamilla@bywatersolutions.com> --- This is an enhancement and will not be backported to the 25.05.x branch. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Jonathan Druart <jonathan.druart@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |41545 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=41545 [Bug 41545] JS warning "redeclaration of let filters_options" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED CC| |david@davidnind.com Resolution|--- |FIXED --- Comment #23 from David Nind <david@davidnind.com> --- No changes requried to the manual. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38311 Bug 38311 depends on bug 38201, which changed state. Bug 38201 Summary: VueJS architecture rethink https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=38201 What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org