[Bug 10343] New: Rename OpacShowHoldNotes to OpacHoldNotes
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Bug ID: 10343 Summary: Rename OpacShowHoldNotes to OpacHoldNotes Classification: Unclassified Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: ASSIGNED Severity: trivial Priority: P5 - low Component: Hold requests Assignee: m.de.rooy@rijksmuseum.nl Reporter: m.de.rooy@rijksmuseum.nl CC: gmcharlt@gmail.com As a QA followup on report 9722. Jonathan suggested to move the pref. I suggested to rename. Then Jonathan suggested: OpacHoldNotes is probably more expressive. In the meantime I also discovered that this pref name came in two flavours: starting with OPAC and with Opac. Unfortunately, there are a lot of prefs starting with OPAC, Opac or opac. Since we are not consistent, I pick Opac for readability :) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |10321 -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #1 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Building this on top of bug 10321. Please apply/test that one first :) -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #2 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 18415 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18415&action=edit Bug 10343: Rename OpacShowHoldNotes to OpacHoldNotes As QA followup on report 9722. Built on top of another followup report 10321. Test plan: Run the db revision included in this patch. Enable OpacHoldNotes. Check that you can add a hold note on opac-reserve. Do you see it on opac-user and in staff on catalog detail of that biblio? Do a grep on ShowHoldNotes on the Koha code: grep -i ignores case. You should find three occurrences only in updatedatabase.pl (the old dbrev and this dbrev renaming them). These are fine. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #18415|0 |1 is obsolete| | --- Comment #3 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 18473 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18473&action=edit Bug 10343: Rename OpacShowHoldNotes to OpacHoldNotes As QA followup on report 9722. Built on top of another followup report 10321. Test plan: Run the db revision included in the other patch. Enable OpacHoldNotes. Check that you can add a hold note on opac-reserve. Do you see it on opac-user and in staff on catalog detail of that biblio? Do a grep on ShowHoldNotes on the Koha code: grep -i ignores case. You should find three occurrences only in updatedatabase.pl (the old dbrev and this dbrev renaming them). These are fine. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 M. de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #18473|0 |1 is obsolete| | --- Comment #4 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 18474 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18474&action=edit Bug 10343: dbrev for rename OpacShowHoldNotes to OpacHoldNotes Renames the pref for install and upgrade. Test plan: See the other patch. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #5 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Created attachment 18475 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18475&action=edit Bug 10343: Rename OpacShowHoldNotes to OpacHoldNotes As QA followup on report 9722. Built on top of another followup report 10321. Test plan: Run the db revision included in the other patch. Enable OpacHoldNotes. Check that you can add a hold note on opac-reserve. Do you see it on opac-user and in staff on catalog detail of that biblio? Do a grep on ShowHoldNotes on the Koha code: grep -i ignores case. You should find three occurrences only in updatedatabase.pl (the old dbrev and this dbrev renaming them). These are fine. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #6 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- Separated the dbrev from the other changes. A merge conflict on the dbrev patch should not be hard to resolve :) Please test them on top of bug 10321. Thanks. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #18474|0 |1 is obsolete| | Attachment #18475|0 |1 is obsolete| | --- Comment #7 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 18757 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18757&action=edit Bug 10343: dbrev for rename OpacShowHoldNotes to OpacHoldNotes Renames the pref for install and upgrade. Test plan: See the other patch. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #8 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 18758 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18758&action=edit Bug 10343: Rename OpacShowHoldNotes to OpacHoldNotes As QA followup on report 9722. Built on top of another followup report 10321. Test plan: Run the db revision included in the other patch. Enable OpacHoldNotes. Check that you can add a hold note on opac-reserve. Do you see it on opac-user and in staff on catalog detail of that biblio? Do a grep on ShowHoldNotes on the Koha code: grep -i ignores case. You should find three occurrences only in updatedatabase.pl (the old dbrev and this dbrev renaming them). These are fine. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #9 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to comment #8)
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Thanks. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA CC| |jonathan.druart@biblibre.co | |m Patch complexity|--- |Trivial patch QA Contact| |jonathan.druart@biblibre.co | |m --- Comment #10 from Jonathan Druart <jonathan.druart@biblibre.com> --- git grep OpacShowHoldNotes returns 0 occurrence. Marked as Passed QA. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #18757|0 |1 is obsolete| | Attachment #18758|0 |1 is obsolete| | --- Comment #11 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 18761 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18761&action=edit Bug 10343: dbrev for rename OpacShowHoldNotes to OpacHoldNotes Renames the pref for install and upgrade. Test plan: See the other patch. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 --- Comment #12 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 18762 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=18762&action=edit Bug 10343: Rename OpacShowHoldNotes to OpacHoldNotes As QA followup on report 9722. Built on top of another followup report 10321. Test plan: Run the db revision included in the other patch. Enable OpacHoldNotes. Check that you can add a hold note on opac-reserve. Do you see it on opac-user and in staff on catalog detail of that biblio? Do a grep on ShowHoldNotes on the Koha code: grep -i ignores case. You should find three occurrences only in updatedatabase.pl (the old dbrev and this dbrev renaming them). These are fine. Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10343 Galen Charlton <gmcharlt@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #13 from Galen Charlton <gmcharlt@gmail.com> --- Pushed to master. Thanks, Marcel! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org