[Bug 33192] New: We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Bug ID: 33192 Summary: We should rename 'AutoEmailPrimaryAddress' to 'EmailFieldPrimary' for clarification Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: System Administration Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com The AutoEmailPrimaryAddress preference no longer only affects AutoEmailNewUser (formerly known as AutoEmailOpacUser). As such I feel it should be clarified and renamed to EmailFieldPrimary to show it is actually being used for the majority of notices now. I chose EmailField* to sit it next to the new preference I attempt to introduce in bug 29046. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |Academy -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=18398 -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=33191 -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |caroline.cyr-la-rose@inlibr | |o.com --- Comment #1 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Martin, Can you specify what it affects exactly? I'll make a note to add this in the manual... Caroline -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- The preferece is used in only one routine, Koha::Patron->notice_email_address. But it appears at some point, this method pretty much supplanted Koha::Patron->first_valid_email_address and is used in a lot more of the codebase. notice_email_address is used in: C4::Auth_With_shibboleth C4::Letters (as the default) C4::Auth - For 2FA C4::Auth_with_ldap C4::Reserves shareshelf.pl memberentry.pl opac-registration-varify.pl two_factor_auth.pl notice.pl memberentry.pl pendingreserves.pl Koha::Ticket Patron::Import.pm suggestion.pl overdue_notices.pl TalkingTech_iteive_outbound.pl notice_unprocessed_suggestions.pm first_valid_email is now only used in: clubs-tab.tt waiting_holds.inc transferstoreceive.tt opac-sendbasket.pl Koha::SharedContent And there's likely a few other cases where we refer more directly to the email fields rather than using the methods. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 148118 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148118&action=edit Bug 33192: Update AutoEmailPrimaryAddress to EmailFieldPrimary This patch updates the database to reflect the new name for the AutoEmailPrimaryAddress system preferences -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 148119 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148119&action=edit Bug 33192: Update all occurrences of AutoEmailPrimaryAddress This patch updates all references to AutoEmailPrimaryAddress to refer to EmailFieldPrimary instead. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |29046 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29046 [Bug 29046] Allow libraries to specify email order for "AutoEmailPrimaryAddress" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #5 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- 1. Add primary, secondary and alternate email addresses in a patron's account - Primary email = primary@... - Secondary email = secondary@... - Email, under Alternate address = alternate@... 2. Set EmailFieldPrimary to home (primary email) 3. In the patron's account click More > Send welcome email 4. Check the message_queue, the to_address should be primary@... select to_address, message_transport_type, letter_code, time_queued from message_queue where date(time_queued) = curdate(); 5. Set EmailFieldPrimary to work (secondary email) 6. Repeat steps 3 and 4, the to_address should be secondary@... 7. Set EmailFieldPrimary to alternate 8. Repeat steps 3 and 4, the to_address should be alternate@... 9. Set EmailFieldPrimary to cardnumber as 10. Repeat steps 3 and 4, the to_address should be the patron's cardnumber 11. Set EmailFieldPrimary to first valid 12. Repeat steps 3 and 4, the to_address should be primary@... 13. Remove the primary email from the patron's account 14. Repeat steps 3 and 4, the to_address should be secondary@... 15. Remove the secondary email from the patron's account 16. Repeat steps 3 and 4, the to_address should be alternate@... If there are no email addresses at all, the notice is not generated. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148118|0 |1 is obsolete| | --- Comment #6 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Created attachment 148139 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148139&action=edit Bug 33192: Update AutoEmailPrimaryAddress to EmailFieldPrimary This patch updates the database to reflect the new name for the AutoEmailPrimaryAddress system preferences Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148119|0 |1 is obsolete| | --- Comment #7 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- Created attachment 148140 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=148140&action=edit Bug 33192: Update all occurrences of AutoEmailPrimaryAddress This patch updates all references to AutoEmailPrimaryAddress to refer to EmailFieldPrimary instead. Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |33191 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33191 [Bug 33191] AutoEmailPrimaryAddress options don't match labels in memberentry -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Text to go in the| |The enhancement renames release notes| |AutoEmailPrimaryAddress the | |system preference to | |EmailFieldPrimary to | |reflect the fact that it is | |not only used in the | |context of | |AutoEmailNewUser, but in | |general for email notices. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |33223 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33223 [Bug 33223] Koha::Patron->notice_email_address isn't consistently used -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com --- Comment #8 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Shouldn't it be EmailAddress instead of Email? It's not a verb, and we have AutoEmailOpacUser where it is used as a verb. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- QA Contact|testopia@bugs.koha-communit |katrin.fischer@bsz-bw.de |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148139|0 |1 is obsolete| | --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 149381 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=149381&action=edit Bug 33192: Update AutoEmailPrimaryAddress to EmailFieldPrimary This patch updates the database to reflect the new name for the AutoEmailPrimaryAddress system preferences Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #148140|0 |1 is obsolete| | --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 149382 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=149382&action=edit Bug 33192: Update all occurrences of AutoEmailPrimaryAddress This patch updates all references to AutoEmailPrimaryAddress to refer to EmailFieldPrimary instead. Signed-off-by: Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 149383 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=149383&action=edit Bug 33192: Fix it-IT sample data and unit tests To test: * prove t/db_dependent/Message.t * Run the it-IT web installer and make sure 'email' is set. Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #149383|0 |1 is obsolete| | --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 149384 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=149384&action=edit Bug 33192: (QA follow-up) Fix it-IT sample data and unit tests To test: * prove t/db_dependent/Message.t * Run the it-IT web installer and make sure 'email' is set. Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #13 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Should not we add the original name in the description, so that the search will return the new one when then old one is searched for? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Jonathan Druart from comment #13)
Should not we add the original name in the description, so that the search will return the new one when then old one is searched for?
Formerly known as... ? :) I am not sure to be honest. I hesitate as that will mean that we will probably never get rid of it and we might end up with a lot of those entries over time. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #15 from Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> --- AFAIK, there is no precedent for this... gist -> TaxRates, gist is not mentioned in the description NotesBlacklist -> NotesToHide, no mention RequestOnOpac -> OPACHoldRequests, no mention etc. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |23.05.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 --- Comment #16 from Tomás Cohen Arazi <tomascohen@gmail.com> --- Pushed to master for 23.05. Nice work everyone, thanks! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |matt.blenkinsop@ptfs-europe | |.com Status|Pushed to master |Needs documenting --- Comment #17 from Matt Blenkinsop <matt.blenkinsop@ptfs-europe.com> --- Enhancement - not backporting to 22.11.x Nice work everyone! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Documentation| |https://gitlab.com/koha-com submission| |munity/koha-manual/-/merge_ | |requests/687 Documentation| |Caroline Cyr La Rose contact| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Caroline Cyr La Rose <caroline.cyr-la-rose@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs documenting |RESOLVED Resolution|--- |FIXED -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |normal -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Aleisha Amohia <aleisha@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |37623 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37623 [Bug 37623] t/db_dependent/Letters.t tests fail to consider EmailFieldPrimary syspref -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33192 Tomás Cohen Arazi <tomascohen@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=37757 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org