[Bug 29625] New: Wrong var name in Koha::BiblioUtils get_all_biblios_iterator
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Bug ID: 29625 Summary: Wrong var name in Koha::BiblioUtils get_all_biblios_iterator Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: fridolin.somers@biblibre.com QA Contact: testopia@bugs.koha-community.org In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED Assignee|koha-bugs@lists.koha-commun |fridolin.somers@biblibre.co |ity.org |m -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Trivial patch Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 --- Comment #1 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 128183 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=128183&action=edit Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #128183|0 |1 is obsolete| | --- Comment #2 from David Nind <david@davidnind.com> --- Created attachment 129629 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129629&action=edit Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #3 from David Nind <david@davidnind.com> --- Testing notes (koha-testing-docker): - 436 records both before and after the patch is applied and index regenerated using Elasticsearch. - Searched in the staff interface catalogue using * - Same number of records as indexed when using Zebra. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com Status|Signed Off |Failed QA --- Comment #4 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Then I would also change the following line: 156 __PACKAGE__->new($marc, $row->biblionumber); -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #129629|0 |1 is obsolete| | --- Comment #5 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 129839 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=129839&action=edit Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 --- Comment #6 from Fridolin Somers <fridolin.somers@biblibre.com> --- (In reply to Jonathan Druart from comment #4)
Then I would also change the following line: 156 __PACKAGE__->new($marc, $row->biblionumber);
Good catch ;) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl --- Comment #7 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Why are there no tests for this routine btw ? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 --- Comment #8 from Fridolin Somers <fridolin.somers@biblibre.com> --- (In reply to Marcel de Rooy from comment #7)
Why are there no tests for this routine btw ?
Oh indeed we should have. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Michal Denar <black23@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Michal Denar <black23@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #129839|0 |1 is obsolete| | --- Comment #9 from Michal Denar <black23@gmail.com> --- Created attachment 130774 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=130774&action=edit Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index Signed-off-by: Michal Denar <black23@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #130774|0 |1 is obsolete| | --- Comment #10 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 130815 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=130815&action=edit Bug 29625: Fix var name in Koha::BiblioUtils get_all_biblios_iterator In Koha::BiblioUtils, get_all_biblios_iterator method is a class level method like get_from_biblionumber. So its first arg should be named $class instead of $self. Even if this var in not used. Test plan : 1) Run Elasticsearch full rebuild with and without patch 2) Check all biblio records are in index Signed-off-by: Michal Denar <black23@gmail.com> Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 --- Comment #11 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Created attachment 130816 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=130816&action=edit Bug 29625: Add test for get_all_biblios_iterator Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |22.05.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 --- Comment #12 from Fridolin Somers <fridolin.somers@biblibre.com> --- Pushed to master for 22.05, thanks to everybody involved 🦄 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)|22.05.00 |22.05.00,21.11.03 released in| | Status|Pushed to master |Pushed to stable CC| |kyle@bywatersolutions.com --- Comment #13 from Kyle M Hall <kyle@bywatersolutions.com> --- Pushed to 21.11.x for 21.11.03 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |andrew@bywatersolutions.com Status|Pushed to stable |Pushed to oldstable Version(s)|22.05.00,21.11.03 |22.05.00,21.11.03,21.05.12 released in| | --- Comment #14 from Andrew Fuerste-Henry <andrew@bywatersolutions.com> --- Pushed to 21.05.x for 21.05.12 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Victor Grousset/tuxayo <victor@tuxayo.net> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to oldstable |RESOLVED Resolution|--- |FIXED CC| |victor@tuxayo.net --- Comment #15 from Victor Grousset/tuxayo <victor@tuxayo.net> --- Not backported to oldoldstable (20.11.x). Feel free to ask if it's needed. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29625 Andrew Fuerste-Henry <andrew@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)|22.05.00,21.11.03,21.05.12 |22.05.00,21.11.03,21.05.13 released in| | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org