[Bug 26248] New: Simplify keep_text Javascript function
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 Bug ID: 26248 Summary: Simplify keep_text Javascript function Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff Client Assignee: koha-bugs@lists.koha-community.org Reporter: dcook@prosentient.com.au QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com The keep_text function in koha-tmpl/intranet-tmpl/prog/js/staff-global.js is functional but not very readable. We can simplify it. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #1 from David Cook <dcook@prosentient.com.au> --- Created attachment 108567 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=108567&action=edit Bug 26248: Simplify keep_text function used in header search The current code is functional but not very readable. This patch simplifies the code to be more readable and to be more efficient. To test: 1) Apply patch 2) Refresh browser cache 3) Type "A" in "Check out" tab 4) Click "Check in" (and other tabs) 5) Observe that text is persisted from original tab 6) Type "B" in "Search the catalog" tab 7) Click "Renew" tab 8) Observe that text is persisted from latest changed tab -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |dcook@prosentient.com.au |ity.org | -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |14189 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14189 [Bug 14189] Make text persist/populate hidden fields for the Staff searchbox -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #2 from David Cook <dcook@prosentient.com.au> --- Hmm working fine on mainpage.pl but having an issue clicking on "Search the catalog" on search.pl... -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #3 from David Cook <dcook@prosentient.com.au> --- For some reason that tab is passing an index value of 4 rather than 3... -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #4 from David Cook <dcook@prosentient.com.au> --- Ahh the keep_text isn't set correctly in "koha-tmpl/intranet-tmpl/prog/en/includes/cat-search.inc" -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |26249 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26249 [Bug 26249] keep_text class not set inconsistently in cat-search.inc -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #5 from David Cook <dcook@prosentient.com.au> --- Adding dependency on Bug 26249 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 Alvaro Cornejo <cornejo.alvaro@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |cornejo.alvaro@gmail.com --- Comment #6 from Alvaro Cornejo <cornejo.alvaro@gmail.com> --- Created attachment 108959 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=108959&action=edit Example pendings on last-borrower As per comment #3 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #7 from Alvaro Cornejo <cornejo.alvaro@gmail.com> --- Comment on attachment 108959 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=108959 Example pendings on last-borrower Sorry wrong bug!!! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #108959|0 |1 is obsolete| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 Mazen Khallaf <mazen.i.khallaf@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 Mazen Khallaf <mazen.i.khallaf@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #108567|0 |1 is obsolete| | --- Comment #8 from Mazen Khallaf <mazen.i.khallaf@gmail.com> --- Created attachment 115262 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=115262&action=edit Bug 26248: Simplify keep_text function used in header search The current code is functional but not very readable. This patch simplifies the code to be more readable and to be more efficient. To test: 1) Apply patch 2) Refresh browser cache 3) Type "A" in "Check out" tab 4) Click "Check in" (and other tabs) 5) Observe that text is persisted from original tab 6) Type "B" in "Search the catalog" tab 7) Click "Renew" tab 8) Observe that text is persisted from latest changed tab Signed-off-by: Mazen Khallaf <mazen.i.khallaf@gamil.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Failed QA --- Comment #9 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I believe there is still a small glitch here: When I - enter something in one tab - move to the next - empty the input field - switch tab again - the deleted string reappears -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 --- Comment #10 from David Cook <dcook@prosentient.com.au> --- (In reply to Katrin Fischer from comment #9)
I believe there is still a small glitch here: When I - enter something in one tab - move to the next - empty the input field - switch tab again - the deleted string reappears
Hmm weird. I thought that I'd thoroughly tested this. I probably don't have time to work on this again for a long time, but that's a useful note! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|dcook@prosentient.com.au |koha-bugs@lists.koha-commun | |ity.org -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26248 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |RESOLVED Resolution|--- |INVALID --- Comment #11 from David Cook <dcook@prosentient.com.au> --- I don't recall why I cared about this in the first place... -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org