[Bug 27033] New: Add plugin hook to add a big link in staff home page
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Bug ID: 27033 Summary: Add plugin hook to add a big link in staff home page Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Staff Client Assignee: koha-bugs@lists.koha-community.org Reporter: fridolin.somers@biblibre.com QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com In staff home page we have some big links : Circulation, Patrons ... Add plugin hook to add such a link. Defined by a CSS class, an URL, a Font Awesome icon and a content. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED Assignee|koha-bugs@lists.koha-commun |fridolin.somers@biblibre.co |ity.org |m -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #1 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 113689 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=113689&action=edit Screenshot -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #2 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 113690 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=113690&action=edit Example plugin -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff Patch complexity|--- |Trivial patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #3 from Fridolin Somers <fridolin.somers@biblibre.com> --- Created attachment 113693 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=113693&action=edit Bug 27033: Add plugin hook to add a big link in staff home page In staff home page we have some big links : Circulation, Patrons ... Add plugin hook to add such a link. Defined by a CSS class, an URL, a Font Awesome icon and a content. In order to porpose a space where those links will show, I propose to create 3 columns of links. The new one will have "About" link (in order to not be empty when no plugins) and links from plugins. Test plan : Use example plugin and see the big link in home page like in screenshot -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #113693|0 |1 is obsolete| | --- Comment #4 from David Nind <david@davidnind.com> --- Created attachment 113758 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=113758&action=edit Bug 27033: Add plugin hook to add a big link in staff home page In staff home page we have some big links : Circulation, Patrons ... Add plugin hook to add such a link. Defined by a CSS class, an URL, a Font Awesome icon and a content. In order to porpose a space where those links will show, I propose to create 3 columns of links. The new one will have "About" link (in order to not be empty when no plugins) and links from plugins. Test plan : Use example plugin and see the big link in home page like in screenshot Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #5 from David Nind <david@davidnind.com> --- LOL! 8-) Love the plugin: Have a break, sign you out of Koha!! Owen might want to have a look at how to make the columns more responsive. For example, when narrowing the size of you screen so that the options flow nicely into one column if the screen width gets too narrow. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au --- Comment #6 from David Cook <dcook@prosentient.com.au> --- I like the idea but I'm not sure about the terminology. I actually clicked on this bug because I had no idea what a "big link" would be hehe. When I worked first-hand in libraries, we would often refer to the "Circulation module", "Cataloguing module", "Acquisitions module", "Serials module", et cetera... so I wonder if "koha_module_link" might be more accurate naming? That said, "About Koha" and "Advanced Search" don't really seem like "modules" to me... "top_nav_link" for the top navigation and "home_nav_link" for the home page navigation? (Or swap out "nav" for "menu" so "top_menu_link" or "home_menu_link"? Again, I really like this idea, but I think having easily understood terminology would be a good idea too. (At first, I thought this bug was another Fridolin Somers April 1st prank where it made links extra big or something 😅.) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |In Discussion --- Comment #7 from Fridolin Somers <fridolin.somers@biblibre.com> --- Indeed the terminology could be better. I prefer "home_nav_link". The goal is to navigate to somewhere, module or more specific page. We already have OPACNav preferences. So hook named : "intranet_home_nav_link". And maybe rename the class "biglinks-list". Other votes ? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #8 from Fridolin Somers <fridolin.somers@biblibre.com> --- (In reply to David Nind from comment #5)
LOL! 8-) Love the plugin: Have a break, sign you out of Koha!!
Owen might want to have a look at how to make the columns more responsive. For example, when narrowing the size of you screen so that the options flow nicely into one column if the screen width gets too narrow.
Those links more responsive would be great. But no idea how to do it 😊 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #9 from David Cook <dcook@prosentient.com.au> --- (In reply to Fridolin Somers from comment #7)
Indeed the terminology could be better.
I prefer "home_nav_link". The goal is to navigate to somewhere, module or more specific page. We already have OPACNav preferences.
So hook named : "intranet_home_nav_link". And maybe rename the class "biglinks-list".
Other votes ?
Sounds good to me. Curious to hear what others think. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- See Also| |https://bugs.koha-community | |.org/bugzilla3/show_bug.cgi | |?id=27527 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com --- Comment #10 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Shouldn't this be actually replaced with bug 15326? Aleisha rewrote it to add a new "page" type of additional contents. It would be a core feature, and plugins could simply add new contents by adding rows to the DB tables. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |DUPLICATE Status|In Discussion |RESOLVED --- Comment #11 from Fridolin Somers <fridolin.somers@biblibre.com> --- Sure, lets close *** This bug has been marked as a duplicate of bug 27527 *** -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27033 --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I am not sure if the CMS is solving this; I think this was to add new module style links to the start page? And possibly add them to the 'More' menu as well? I think it could still be done with the js hook if needed. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org