[Bug 17279] New: Edifact:: Line quantity should ensure its returning invoiced quantity
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 Bug ID: 17279 Summary: Edifact::Line quantity should ensure its returning invoiced quantity Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Acquisitions Assignee: koha-bugs@lists.koha-community.org Reporter: colin.campbell@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org Edifact::Line 's quantity method is currently used in the context of receipting from an invoice, but the line object only looks at tag in populating the value. It should check the quantity qualifier to ensure that another type of quantity is not being incorrectly returned. The method should be renamed to be more specific e.g. invoiced_quantity rather than quantity, in order to self document -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 Colin Campbell <colin.campbell@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |colin.campbell@ptfs-europe. |ity.org |com Status|NEW |Needs Signoff --- Comment #1 from Colin Campbell <colin.campbell@ptfs-europe.com> --- Created attachment 55344 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=55344&action=edit Proposed Patch Tests added to Edifact.t and EdiInvoice.t to ensure correct values returned Realised the need when only one copy of 6 got receipted at a site because invoice included multiple delivery instructions (each with a qty of 1) -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Failed QA --- Comment #2 from Owen Leonard <oleonard@myacpl.org> --- How should this be tested? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 --- Comment #3 from Colin Campbell <colin.campbell@ptfs-europe.com> --- (In reply to Owen Leonard from comment #2)
How should this be tested?
The unit tests check that the two fields are now being returned separately as expected. Previously they were not distinguished. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |katrin.fischer@bsz-bw.de --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Should this be FAILED QA? -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17279 Colin Campbell <colin.campbell@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |DUPLICATE Status|Failed QA |RESOLVED --- Comment #5 from Colin Campbell <colin.campbell@ptfs-europe.com> --- Distinction is maintained by code in patch 18267 which incorporates tests from this *** This bug has been marked as a duplicate of bug 18267 *** -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org