[Bug 7540] New: Add ids to the legend elements to make it easier to tweak with javascript
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Bug #: 7540 Summary: Add ids to the legend elements to make it easier to tweak with javascript Classification: Unclassified Change sponsored?: --- Product: Koha Version: master Platform: All OS/Version: All Status: NEW Severity: enhancement Priority: P5 - low Component: Patrons AssignedTo: kyle.m.hall@gmail.com ReportedBy: robin@catalyst.net.nz QAContact: koha.sekjal@gmail.com CC: gmcharlt@gmail.com This adds some IDs to the legends to make them easier to alter without customising templates. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Robin Sheat <robin@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED AssignedTo|kyle.m.hall@gmail.com |robin@catalyst.net.nz -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 --- Comment #1 from Robin Sheat <robin@catalyst.net.nz> 2012-02-14 23:37:47 UTC --- Created attachment 7648 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7648 Bug 7540 - add id values to the legends in the patron entry form This adds the following IDs to the legends in the patron entry form: main_address_lgd contact_lgd alt_address_lgd alt_contact_lgd library_management_lgd library_setup_lgd opac_staff_login_lgd patron_messaging_prefs_lgd With these in place, then jquery like: $(document).ready(function(){ $('#main_address_lgd').text('Postal Address'); $('#alt_address_lgd').text('Residential Address'); }); in intranetuserjs can be used to rename things to taste. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Robin Sheat <robin@catalyst.net.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 --- Comment #2 from Robin Sheat <robin@catalyst.net.nz> 2012-02-14 23:47:40 UTC --- Created attachment 7649 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7649 Bug 7540 [3.6.x] - add id values to the legends in the patron entry form This adds the following IDs to the legends in the patron entry form: main_address_lgd contact_lgd alt_address_lgd alt_contact_lgd library_management_lgd library_setup_lgd opac_staff_login_lgd patron_messaging_prefs_lgd With these in place, then jquery like: $(document).ready(function(){ $('#main_address_lgd').text('Postal Address'); $('#alt_address_lgd').text('Residential Address'); }); in intranetuserjs can be used to rename things to taste. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Liz Rea <wizzyrea@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #7648|0 |1 is obsolete| | --- Comment #3 from Liz Rea <wizzyrea@gmail.com> 2012-02-16 04:22:28 UTC --- Created attachment 7675 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=7675 Bug 7540 - add id values to the legends in the patron entry form This adds the following IDs to the legends in the patron entry form: main_address_lgd contact_lgd alt_address_lgd alt_contact_lgd library_management_lgd library_setup_lgd opac_staff_login_lgd patron_messaging_prefs_lgd With these in place, then jquery like: $(document).ready(function(){ $('#main_address_lgd').text('Postal Address'); $('#alt_address_lgd').text('Residential Address'); }); in intranetuserjs can be used to rename things to taste. Signed-off-by: Liz Rea <wizzyrea@gmail.com> I see the id's in there, they appear consistent and complete. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Liz Rea <wizzyrea@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off CC| |wizzyrea@gmail.com -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Ian Walls <koha.sekjal@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA --- Comment #4 from Ian Walls <koha.sekjal@gmail.com> 2012-02-16 17:06:21 UTC --- Template only change to add unique ID attributes to elements (always a good thing). Marking as Passed QA. -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Paul Poulain <paul.poulain@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master CC| |paul.poulain@biblibre.com Version|master |rel_3_6 Severity|enhancement |minor --- Comment #5 from Paul Poulain <paul.poulain@biblibre.com> 2012-02-17 10:55:28 UTC --- changed importance to "minor", it's not really an ENH. chris_n, there is a 3.6 patch for this one -- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7540 Jared Camins-Esakov <jcamins@cpbibliography.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable --- Comment #6 from Jared Camins-Esakov <jcamins@cpbibliography.com> --- This patch will be included in the upcoming 3.6.5 release. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org