On Wed, Jun 27, 2012 at 05:38:27PM +0200, Claire Hernandez wrote:
I would rename things to have easier and smaller names to remember and would move things:
- BusinessLogic renamed in Service - DBObject renamed in Data - DB tables in Schema
Like this, we have one "layer" less (KISS): before: BusinessLogic -> DBObject -> DB -> Schema (-> means "use") after: Service -> Data -> Schema
I agree wholeheartedly. Its much more succinct and captures what we're trying to model. (plus I'm sure I'll get sick of fixing my missspellings of BusinessLogic) Colin -- Colin Campbell Chief Software Engineer, PTFS Europe Limited Content Management and Library Solutions +44 (0) 800 756 6803 (phone) +44 (0) 7759 633626 (mobile) colin.campbell@ptfs-europe.com skype: colin_campbell2 http://www.ptfs-europe.com