http://wiki.koha-community.org/wiki/Koha_Namespace_RFC, moving ahead
Hello koha-devel, After our discussions during the hackfest, a wiki page has been written. Now, it's time for the first patches, to see how it could look like. I made some work on bug 8309. That's not a request for signoff, but to look at the code, comment, discuss, ... Note: if you want to play with those patches, look in admin/categories.pl and testrelations.pl. You'll have to install Moose and DBIx::Class, (available on probably all linux distros) -- Paul POULAIN http://www.biblibre.com Expert en Logiciels Libres pour l'info-doc Tel : (33) 4 91 81 35 08
On 25/06/2012 15:17, Paul Poulain wrote:
Hello koha-devel,
After our discussions during the hackfest, a wiki page has been written. Now, it's time for the first patches, to see how it could look like. I made some work on bug 8309. That's not a request for signoff, but to look at the code, comment, discuss, ...
Note: if you want to play with those patches, look in admin/categories.pl and testrelations.pl. You'll have to install Moose and DBIx::Class, (available on probably all linux distros) Hello,
I would rename things to have easier and smaller names to remember and would move things: - BusinessLogic renamed in Service - DBObject renamed in Data - DB tables in Schema Like this, we have one "layer" less (KISS): before: BusinessLogic -> DBObject -> DB -> Schema (-> means "use") after: Service -> Data -> Schema Data become the only thing to call Schema DBIx::Class and seems to me more clear (if object needs only one table, ok, we'll have a very simple object and crud sub if object needs more agregation, the crud sub can become - a little bit - more complex). If I take time I could propose new patches but discussion before is important too ;) In France we have "fpw" this weekend (2 days only for perl conferences and hacking), 6 from BibLibre will attend. It will be a place to ask about modern ways to do perl nowadays and feelings about some libraries we could use will be welcomed. Claire.
On Wed, Jun 27, 2012 at 05:38:27PM +0200, Claire Hernandez wrote:
I would rename things to have easier and smaller names to remember and would move things:
- BusinessLogic renamed in Service - DBObject renamed in Data - DB tables in Schema
Like this, we have one "layer" less (KISS): before: BusinessLogic -> DBObject -> DB -> Schema (-> means "use") after: Service -> Data -> Schema
I agree wholeheartedly. Its much more succinct and captures what we're trying to model. (plus I'm sure I'll get sick of fixing my missspellings of BusinessLogic) Colin -- Colin Campbell Chief Software Engineer, PTFS Europe Limited Content Management and Library Solutions +44 (0) 800 756 6803 (phone) +44 (0) 7759 633626 (mobile) colin.campbell@ptfs-europe.com skype: colin_campbell2 http://www.ptfs-europe.com
I would rename things to have easier and smaller names to remember and would move things:
- BusinessLogic renamed in Service - DBObject renamed in Data - DB tables in Schema
Like this, we have one "layer" less (KISS): before: BusinessLogic -> DBObject -> DB -> Schema (-> means "use") after: Service -> Data -> Schema
Data become the only thing to call Schema DBIx::Class and seems to me more clear (if object needs only one table, ok, we'll have a very simple object and crud sub if object needs more agregation, the crud sub can become - a little bit - more complex).
+1 from me as well. Regards, Jared
participants (4)
-
Claire Hernandez -
Colin Campbell -
Jared Camins-Esakov -
Paul Poulain